Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Koff and outlook 2010 (slow performance)
  •  
stresslein

Messages: 9
Karma: 0
Send a private message to this user
Hi everybody, Crying or Very Sad

we have nearly the samr issue like realnetwork (#126857) from Jan 2016

new installation, kerio is installed on a brandnew IBM Server with 32GB RAM
2012R2 OS installled, 10 Workstations with win7, outlook 2010 or 2013 installed
on both, server and WS is Kerio 9.0.1 installed
when the customer starts outlook, it takes a long time to start (up to 1 minute)
but after that, when he changed the folders from f.e incoming to sent items, or any archive folders
it takes up to 5-10 minutes, to display the content, the next folder the same problem
it looke like that users with large mailboxes are affected, we are talking about >10.000 Mails
in each folder (inbox and sent items)
i´ve done so many test, like realnetwork , with index, addons disbled, caching , new notebooks to doublecheck whether the workstations are the problem or not, every time the same issue

sometiomes its not fast, but they can work wth kerio, most of time it´s incredible slow
and the don´t want work with kerio any longer
I need a fast solution or we will loose the customer because of Koff client

for your information, the same Workstations with Webinterface works really fine,
without any problems in seconds, so it´s a problem with Koff

what can i do, any ideas are welcome

Chris


  •  
Maerad

Messages: 158
Karma: 31
Send a private message to this user
Well - congratulations, you just found a quite common outlook problem.

This has almost nothing to do with kerio, I had the same behavior with exchange too. The Kerio Connect Webclient only lists like 40 messages. Outlook on the other hand, displays EVERYTHING in the folder. If there are 20k mails in it, it will load them all. Just open the folder in Outlook and see the CPU and HDD spike in the taskmanager.

There are two ways to help there.

Cheapest:
Create a subfolder "archive" and maybe after years (2008, 2009 ...) and archive the mails older like 3 years there. This WONT impact their work! They can search in the mail folder and if nothing is found, they just need to hit the "search all folders" button.

External Software:
The program mailstore archives the mail by itself, so the user only has the most current stuff ready in outlook. Older mail is archived separately. Works but costs.

And a third thing comes to mind.

The server itself looks ok (SAS Raid 10 or something like that? SATA is baaddd) but the problem might be the client. KOFF saves the mails from the server in a local cache (userfolder somewhere) for offline browsing and because MS is a dick (and keeps a exchangelike connection for outlook itself). That means, if your client loads a folder, it's loaded from their local disk and synced with the server. If the client lacks a bit cpu power, ram or has a slow sata disk, it might also be a problem.

A fast and clean way to change that - get a cheap SSD with enough space for their mails (check the cache size) and set a registry key for the cache to the SSD. I do that on a terminal server enviroment with 25 users and it's fast like nothing else. No problems so far Smile
  •  
Brian (GFI/Kerio)

Messages: 778
Karma: 79
Send a private message to this user
Another option is to use the Exchange ActiveSync type of account. It uses the native Outlook database so loading data is faster compared to the Kerio Outlook Connector.
[img]http://kb.kerio.com/assets/Connect/en/connect-oleas2.png[/img]

Brian Carmichael
Instructional Content Architect
  •  
Maerad

Messages: 158
Karma: 31
Send a private message to this user
Quote:
Another option is to use the Exchange ActiveSync type of account. It uses the native Outlook database so loading data is faster compared to the Kerio Outlook Connector.
[img]http://kb.kerio.com/assets/Connect/en/connect-oleas2.png[/img]


Wohowww... Wait a second

http://kb.kerio.com/product/kerio-connect/email-clients/acti vesync/creating-exchange-activesync-accounts-in-microsoft-ou tlook-1755.html

He said he has 2010 and 2013 Outlook. The feature only works with 2013 and 2016. AND it has some downsides too.
  •  
stresslein

Messages: 9
Karma: 0
Send a private message to this user
Dear Maerad,

first of all thanx for your fast help and input
but, that´s what i´ve done 1 week ago,
and i can´t see any other significant behavior
i moved a lot of mails into some "Archive" Folders, but i must wait sometimes up to 5 min.
when i change from inbox to any othe Folder, not every time but mostly
and yes, we have installed mailstore because we know this program, but not configured right now, we will do it this Weekend, hopefully it helps

and many thanks for the Performance idea with ssd and sata.
it´s a raid, as i know raid 5 with SAS HD´s, but i will doublecheck
so you mentioned that sync between the local Cache file and the Server Folder structure could be the problem, i dont know how often the Client syncronize, every time interval of f.e. 15 min or just at Outlook start ? can i Change any other Parameters in this way
or ist the koff client fix, without any Settings
otherwise i will change the Location for the Cache file and see what happens

many thanks again
and i will Report again

Chris
  •  
Maerad

Messages: 158
Karma: 31
Send a private message to this user
stresslein wrote on Thu, 04 February 2016 08:26

first of all thanx for your fast help and input
but, that´s what i´ve done 1 week ago,
and i can´t see any other significant behavior
i moved a lot of mails into some "Archive" Folders, but i must wait sometimes up to 5 min.
when i change from inbox to any othe Folder, not every time but mostly
and yes, we have installed mailstore because we know this program, but not configured right now, we will do it this Weekend, hopefully it helps


Some other ideas come to mind.
- KOFF correct version for the server?
- Any special OutlookAddins?
- Did you exclude KOFF (.exe) and/or the cache folder from any kind of antivirus check?
- Does the antivirus have some kind of packet inspection firewall thing, that could interfere with the data send/received?
- Do you use redirected userfolders? KOFF saves the cache in the user dir and if that is synced with the server, it's a eavy impact on performance. Here's the different cache usefull.

Also please open the taskmanger and resource manager and if outlook hangs, check the programs that go batshit. Might be a clue too.

Quote:
it´s a raid, as i know raid 5 with SAS HD´s, but i will doublecheck
so you mentioned that sync between the local Cache file and the Server Folder structure could be the problem, i dont know how often the Client syncronize, every time interval of f.e. 15 min or just at Outlook start ? can i Change any other Parameters in this way
or ist the koff client fix, without any Settings
otherwise i will change the Location for the Cache file and see what happens


I guess the server should be ok, even with a raid 5 with SAS HDD (10-15k ones) should be ok. YOu could also check the server usage on cpu and hdd to be sure.

You can also check my other thread when we started with kerio and how we sucesfully used it on a terminal server with 20-25 users and cache on SSD with deplyment automagically and with gpo.

http://forums.kerio.com/m/108341/#msg_108341
  •  
stresslein

Messages: 9
Karma: 0
Send a private message to this user
Dear Maerad,

just as a Feedback
we installed Mailstore this weekend and "moved" thousands of Mails to the Archive System
without success
the inbox and all other Folders are much smaller, less then 5000 Mails
but the issue is the same , no difference in Outlook
searching or changing the Folder ist as slow as before
the next step will be a SSD and changing the Cache file path
hopefully it helps, otherwise i have no idea what i can do

Thanks Chris
  •  
Behn EDV

Messages: 13
Karma: -1
Send a private message to this user
We had the same problem with a very slow behavior of Outlook 2010.
The used PC arent very slow but the problem get worser und worser.
Some Users had more than 20000-30000 mails.
After a change of the harddrive to a SSD (Samsung EVO 850) the problems there solved!

so i can VERY recommend to chance to a SSD if you have this problems.
Previous Topic: External webserver cant send error 550 5.7.1 Authentication Required
Next Topic: setting access rights to shared mail folder for the whole company
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 08:05:33 CET 2017

Total time taken to generate the page: 0.00420 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.