Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Options on Auto attendant not working
  •  
ESP Projects

Messages: 132
Karma: 5
Send a private message to this user
I am trying to get the Kerio Softphone working (which is another problem) but it seems that whenever I tick "NAT Enabled (Kerio operator is behind a firewall)" The options on the auto attendant seem to become unresponsive. the message plays fine, but it doesn't respond to any of the options set up, or even direct dialing to extensions. I have opened all the ports needed as far as i am aware, 443, 4021, 80, 5060 and the RTP range 10000 - 19999 on our firewall. Any ideas?

on a side note, I can't seem to connect the Kerio Softphone to our operator either internally or externally. We have a signed SSL certificate. It seems to cause the problem above when we try to connect the phone to it?
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
Do the troubleshooting tips in http://kb.kerio.com/1320 resolve your issue with the softphone?

[Updated on: Fri, 19 February 2016 18:37]


Ken Snyder
  •  
ESP Projects

Messages: 132
Karma: 5
Send a private message to this user
The main issue at the moment is actually the options not working when we have NAT enabled ticked. I've just dome some testing and it definitely is this setting which stops the options from working. The system completely ignores the fact the user is pressing numbers. Any ideas?
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
I'd be inclined to ask what DTMF method your SIP provider uses (http://kb.kerio.com/1732), but if you're saying this occurs only when the NAT box is ticked, then perhaps that's not relevant.

I notice you haven't mentioned SIP TLS (5061) being enabled. Can you enable that and try again?

Ken Snyder
  •  
ESP Projects

Messages: 132
Karma: 5
Send a private message to this user
The Auto attendant issue seems to be resolved changing the DTMF method as you said, thanks.

Now i am getting a username/password error on the softphone, the Kerio operator logs show the error: Softphone: Failed to open session for user "USERNAME" from host "PUBLIC_IP".
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
A few things to check:

1. Does the provision URL contain "https://" at the beginning of the URL?

2. In the admin console, on Provisioned Phones-->Softphones tab, is the user/extension that you're trying to use with the Softphone appearing in the list?

3. On the softphone, the UserName should be something like, "ksnyder" (in my case) and not a SIP UserID like you might be accustomed to (such as, "1029" if my extension were 1029). The password should also be the one associated with the user & not the SIP password that's associated with the extension itself.

4. Lastly, in KB 1320 that I referenced earlier, does toggling the "Verify TLS Cert" option eliminate the message and get that phone successfully registered?


Ken Snyder
  •  
ESP Projects

Messages: 132
Karma: 5
Send a private message to this user
Thanks for the reply. In answer to your questions,
#1 yes
#2 yes
#3 i'm able to log in to the kerio operator client (Web interface) with the details i'm trying to use (Username and password)
#4 I have just tried without the verify cert option, and get the same message. What i have found out though is that I CAN register successuflly with a user account that was created in Operator, but NOT with a user account that has been imported from our Active Directory. Is this a known issue or could I just have some strange settings with our LDAP sync? I seem to be able to import users still and passwords sync fine.

Going forward,how can I get Operator to work with the certificate? Am i correct in that there will be no encryption while the cert is being ignored?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
As to certificates, please see http://kb.kerio.com/product/kerio-operator/server-configurat ion-kerio-operator/configuring-ssl-certificates-817.html

You can use either a self-signed certificate, or a certificate signed by a certification authority. The communication will be encrypted in both cases. The self-signed certificate does not protect you from man-in-the-middle attacks as smartphones don't let you add the self-signed certificate as a trusted one and the only way is to disable the certificate verification in the softphone application.

The log message you mention ("Softphone: Failed to open session...") means that you have either incorrect username or password so please do check you are using the correct credentials ( http://kb.kerio.com/product/kerio-operator/softphone-setup/c onfiguring-kerio-operator-softphone-1320.html)
Previous Topic: Call Queue Administrator
Next Topic: Prepend caller ID in auto attendant script *feature reqeust?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 18:46:37 CET 2017

Total time taken to generate the page: 0.00430 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.