Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » supports KOC kerio & Exchange-Accounts? (Problems with sending Emails if mutliple Accounts in Outlook2010)
  •  
asti

Messages: 2
Karma: 0
Send a private message to this user
Hello,

the Situation:
Outlook 2010 has configured with 1 Kerio-account (incl. Kerio Outlook Connector) and 1 exchange account.
As a standard mails are sent by the Kerio-Account.

If i will send an email to an address within the exchange-domain, and my kerio-account is explicitly the sending address, the mail will be delivered by the exchange-account, not the kerio-account.

Maybe i can live with this behavior, but the sending email-address will also be changed to the address of the exchange-account.

I can proof this by looking at the mailheader: the originating ip is not the kerio-server, but its the exchange-server.


The exchange-account is used for contacts & calendar of the exchange-domain (different from kerio-domain).
Mail conversation between this two domains should also be possible, but due to incorrect reply-addresses this is not comfortable.

Same behavior in Outlook 2013.

Has anyone hints?

greetings
asti


ps: sorry for broken english

[Updated on: Thu, 31 March 2016 11:50]

  •  
Pavel Dostal (Kerio)

Messages: 181
Karma: 5
Send a private message to this user
Is the address in exchange-domain in SMTP format? Even if you explicitly select Kerio Outlook Connector as sending service, it can't handle addresses in X.400 format.

Pavel Dostal
Kerio Technologies
  •  
asti

Messages: 2
Karma: 0
Send a private message to this user
How can I check that? Its an Exchange 2010

Emailaddresses are shown as the typical user<_at_>domain.tld

after a quick webreseach all i can say: i never had typed in an address in x.400
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Having exactly the same problem, so I thought I'd dig this up.

I have a Kerio and an Exchange account set up in my Outlook 2010 profile. Same goes for me: Even if the Kerio account is chosen as the "From" account in Outlook, all mails _to_ recipients in the Exchange domain will be transferred via the Exchange host, not the Kerio host.

This results in the Exchange host giving an error message when sending an e-mail to two recipients of which one is in the Exchange domain and one is in the Kerio domain.

Scenario:
- I have set up nico@keriodomain.com with KOFF and nico<_at_>exchangedomain.com via Exchange autoconfig (Outlook Anywhere)
- I want to send a mail to john@keriodomain.com and jane<_at_>exchangedomain.com
- Mail to john<_at_>keriodomain.com gets delivered
- Mail to jane<_at_>exchangedomain.com doesn't get delivered
- I get an Outlook-generated Error e-mail in my nico@exchangedomain.com account, error [0x80070005-0x0004dc-0x000524] (not allowed to send on behalf of user). I'm quite sure this is because Outlook tries to send a mail with nico<_at_>keriodomain.com From address via Exchange server, and of course keriodomain.com isn't set up in the Exchange server, so I'm not allowed to send an e-mail with keriodomain.com sender address via exchangedomain.com server
- Also, in the headers of the delivered message to john<_at_>keriodomain.com, I see in the To: header that Jane's address has been somehow cleared out, it looks like this:
To: Jane Doe <>, john<_at_>keriodomain.com

- Jane only has an SMTP address set, no X.400 address

Also I noticed that, in the Outlook status bar, 2 e-mails are sent when I try it like this. So my guess is: Outlook tries to be intelligent and send mails to exchangedomain.com always via the Exchange account, regardless of the "From" account I've set in the "New Mail" window.
If I only send mails to addresses not in the Exchange domain, only one mail will be sent to KOFF/Kerio Connect Server, and then the server handles the distribution to the multiple recipients I specified.

Does anyone know any way to teach Outlook: Please DON'T try to be intelligent and ALWAYS use the specified "From" account for mail delivery, even though you see that there's one or more recipients in the domain in which my Exchange account is as well?

What's also quite annoying: Even if I send a mail only to jane@exchangedomain.com, Outlook will ignore my "From" setting and send it as nico<_at_>exchangedomain.com, as can be seen in the headers as well.

[Updated on: Wed, 21 December 2016 18:08]

  •  
Pavel Dostal (Kerio)

Messages: 181
Karma: 5
Send a private message to this user
I'll try to explain this behavior. I can't be 100% sure it is the correct explanation, nevertheless it is very likely.

First, service used in From field is not something absolute. It is used as from name (at least in KOFF) and it is a hint for Outlook what transport provider should be used as the first. However, every transport provider can report back to Outlook that address scheme of some reciepient is unknown. Outlook tries other transport provider in such situation (and reports error if no transport provider is able to handle such recipient).

Fine, you have email for john<_at_>keriodomain.com and jane<_at_>exchangedomain.com.

First thing KOFF does during sending is asking Outlook to resolve recipients. It means that names (or email address) is replaced by recipient object from address book. The first recipient is probably resolved as some item from KOFF contact folder, the other one is probably contact from AD.

Next, KOFF transport provider checks both recipient for property PR_EMAIL_ADDRESS. It is found for first recipient, however it is not found for the other one (we know it's not there as it would be in To header in the mail delivered to john). So KOFF sends message to john<_at_>keriodomain.com, however reject recipient jane.

Outlook tries other transport provider (Exchange), however it rejects the mail as well, this time because of sender address used in the mail.

I suppose the issue is caused by exchange contacts keeping SMTP address in the property PR_SMTP_ADDRESS (as PR_EMAIL_ADDRESS had been used for x.400 address). KOFF should probably try to find SMTP address in both properties. However it doesn't help you right now. Unless you can somehow make exchange addressbook to fill SMTP address to PR_EMAIL_ADDRESS (I'm not sure it is possible), I see two workarounds.

First, allow nico<_at_>keriodomain.com to sent messages on behalf of nico<_at_>exchangedomain.com

Second, create KOFF contacts with exchange domain addresses and different name (e.g. JaneEx). When you select JaneEx as a recipient, it will be resolved as KOFF contact with correct email address.

Pavel Dostal
Kerio Technologies
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Pavel, thank you so much for this detailed explanation - makes absolute sense with my Outlook experience.
I will give your workarounds a try and get back to you with my feedback.
Again, a huge thank you for your effort so far, it makes a lot much clearer to me already!
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Hey everyone,

I tried both parts of Pavel's solutions, but I'm out of luck.

Since the exchangedomain.com domain is a Hosted Exchange, I cannot allow users of exchangedomain.com to send on behalf of users in keriodomain.com - I can only grant these rights within the domain, which makes perfect sense of course. But, because of this I can't trick the Exchange server into allowing this scenario.

Second, if I try to add jane<_at_>exchangedomain.com to my Kerio address book, Outlook just gives a generic error message on clicking "Save & Close", which is: "The operation failed. The messaging interfaces have returned an unknown error. If the problem persists, restart Outlook."

I tested it with Outlook 2016 and 2010, same behavior.

I was lucky, though, with Outlook 2016 (still have to test it on 2010) by setting the Exchange account and store as default in Outlook's Account Settings. Funnily, it now shows the Exchange account's quota and other settings in the "File" menu when the Kerio account is selected, and vice versa, but it works flawlessly. I have to dig deeper into this, but this appears to be one solution, although it's not all too clean, I'm afraid.

  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Okay, I'm not quite sure what about this did the trick, but on Outlook 2010 and 2016 I was successful by doing this:

* Delete the Exchange account from my Outlook profile
* Create it again, restart Outlook
* Set it as default in the Account Settings
* Create the exchangedomain.com recipients as contacts in the Kerio account's address book

Now it works flawlessly. As I said, I don't exactly why this does the trick, but I could reproduce this several times on both my available Outlook versions, so I guess this could be seen as a (dirty) solution.
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
PS: Yup, it's dirty and has one more-or-less major letdown. Due to an inconsistent configuration, Free/Busy queries from the Kerio server don't work anymore. I debugged that with Outlook debug logging and this is because, when I create a new appointment in my default Kerio calendar, Outlook tries to query https://exchangedomain.com/EWS/exchange.asx instead of https://keriodomain.com/EWS/Exchange.asmx. Of course, the Exchange server doesn't know anything about the appointments (error message is obviously "Unable to resolve e-mail address john<_at_>keriodomain.com to an Active Directory object.") of the Kerio domain users.

So there's no way to force Outlook to handle the two accounts strictly separated? No "trying to resolve e-mail addresses", just please work in the context I'm currently in?
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Sigh, more flaws.. If someone from exchangedomain.com sends mails to both keriodomain.com and exchangedomain.com, the keriodomain user (who has both a Kerio and an Exchange account in his profile) cannot "Reply all" since the exchangedomain.com's recipients e-mail addresses appear empty in the mail in the keriodomain.com inbox.

I had some tries with Outlook 2016 and adding the exchangedomain.com account via ActiveSync instead of Exchange (Mapi-over-https). That worked fine for mails, contacts and calendars, but ActiveSync does not support colors and extended flags (reminders, dates...) - only the "basic" flag (flagged/not flagged).
My users need the extended flagging as well as colors - i.e., full Exchange functionality for both the Exchange and the Kerio account.

So, having both accounts together in Outlook would be most convenient in terms of work organization for my users, but with all this address resolving issue stuff, it's really a pain, and of course this is no particular Kerio issue, but an Outlook one. It's pretty frustrating... Sad
Previous Topic: iPhone SE push notification not going correctly
Next Topic: Do Not Reply Email Filter
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Aug 18 12:33:25 CEST 2017

Total time taken to generate the page: 0.00468 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.