Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » DNS Entry for Certain Domain
  •  
gskibum

Messages: 36
Karma: 1
Send a private message to this user
I'm getting a test Kerio Connect set up in a test environment I have.

My production environment is in one VLAN and the DNS zone is "pretendco.com" This mail is not being hosted internally.

The test environment is in another VLAN and the DNS zone is "pretendco.net" This is where I have installed the test Kerio Connect.

I'm running Mac servers on El Capitan & Server 5.x providing DNS and Open Directory.

I'm running a Kerio Control firewall.

Everything is working great on the Kerio Connect with one exception. Mail sent to users in the pretendco.com domain get stuck in the queue with the error "4.4.1 Cannot find hostname pretendco.com in DNS."

There must be a DNS entry I need to add, but I am at a loss about what that may be. Or perhaps there is some kind of change to the SMTP server I need to make.

I'm able to browse to both internally and externally hosted pretendco.com servers, including www.pretendco.com so the DNS is most of the way there. I'm just missing thie one piece.

Thank you.
  •  
Bud Durland

Messages: 387
Karma: 42
Send a private message to this user
From the machine hosting "pretendco.net", what gets returned as the MX record for "pretendco.com"? This should come back as an FQDN, such as 'mail.pretendco.com'. Can you then (from the test server) PING 'mail.pretendco.com' ?

[Updated on: Thu, 14 April 2016 19:48]

  •  
gskibum

Messages: 36
Karma: 1
Send a private message to this user
Thank you that is helpful. We're getting close. I'm wondering why this hasn't been an issue before and why I haven't noticed it before.

On the machine hosting pretendco.net host lookups of pretendco.com return nothing. The same thing happens when I do host lookups of pretendco.com from devices in pretendco.com. However when I do lookups of pretendco.com from remote locations, I get the correct lookup.

So something is amiss in my pretendco.com DNS.
  •  
gskibum

Messages: 36
Karma: 1
Send a private message to this user
Edit:

After correcting the DNS and got the pretendco.com to look up properly on the box hosting Kerio Connect, and some waiting for Kerio Connect to pick up the changes (the host picked up the changes right away, but the Kerio Connect took longer) messages stopped getting stuck in the queue.

Thank you for pointing me in the right direction.

[Updated on: Fri, 15 April 2016 02:30]

  •  
Carsten Maas (Kerio)

Messages: 247
Karma: 27
Send a private message to this user
A restart of the Kerio Connect service/server can sometimes speed up things in such cases.

Carsten Maas
Senior Technical Marketing Engineer
Kerio Technologies

Kerio Deutschland youtube Channel
http://www.youtube.com/KerioDeutschland
Previous Topic: Restart needed to see kerioantispam debug messages
Next Topic: Kerio Connect and Yosemite Server.app
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Aug 21 19:50:42 CEST 2017

Total time taken to generate the page: 0.00444 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.