Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Redirect from http to https (Is it possible to redirect users from non-secure url to secure)
  •  
jcooper

Messages: 61
Karma: 3
Send a private message to this user
Hi,

Wondering if there's a way to redirect users who just type mail.domain.com into their browser to have them automatically redirected to https://mail.domain.com. Right now, they just get an error(connection refused) which makes sense I guess since I have http turned off. But I'd like to bounce the users to the right url.

Thanks,

Jeff
  •  
ComputerBudda

Messages: 104
Karma: 5
Send a private message to this user
If they type the https the first time, afterwards, it uses that. At least on my systems it does.
  •  
Carsten Maas (Kerio)

Messages: 247
Karma: 27
Send a private message to this user
Have you set the redirect to https in Kerio Connect?
In Kerio Connect the setting to force secure connections is located in the security section -> security policy.

Carsten Maas
Senior Technical Marketing Engineer
Kerio Technologies

Kerio Deutschland youtube Channel
http://www.youtube.com/KerioDeutschland
  •  
jcooper

Messages: 61
Karma: 3
Send a private message to this user
I don't see a redirect option at all. I'm still on 9.0.2. Is is a brand new thing (9.0.3)?

Thanks,

Jeff
  •  
Carsten Maas (Kerio)

Messages: 247
Karma: 27
Send a private message to this user
It is in the product already for a long time. See the attached screenshot:


Carsten Maas
Senior Technical Marketing Engineer
Kerio Technologies

Kerio Deutschland youtube Channel
http://www.youtube.com/KerioDeutschland
  •  
jan.vykoupil

Messages: 3
Karma: 0
Send a private message to this user
Hi, I tried the steps mentioned above but our webmail works only via https even when changing the security policy to none.

We are using Kerio Control (7.4.2), where theres http and https services allowed, but I dont see any rule which forces the webmail to be only on https.

I just cant find where the problem might be. Any suggestions?

Thnak you
  •  
MacLab

Messages: 213
Karma: 15
Send a private message to this user
Sounds like a port mapping issue

MacLab, Inc.
Kerio Certified Partner, Reseller, Hosting Provider, Kerio Connect Certified.
http://maclaboratory.com
  •  
lodewijk

Messages: 93
Karma: 1
Send a private message to this user
are you saying one should redirect port 80 to the https port on the router/firewall to get this to work?

if so, what about internal clients wanting to connect to the web client?

[Updated on: Sun, 29 January 2017 13:17]

  •  
jan.vykoupil

Messages: 3
Karma: 0
Send a private message to this user
i can connect to webmail internaly, externaly (domain name), through public ip but only through https, when i try to connect to http it does not respond, the browser just says cant connect, but ping works on both http and https

somebody before me somehow configured it this way, but i cant find where he did the changes (no rule either in kerio control or kerio connect), so i thought somebody might help me, i also tried these setting written in this post but the behavior does not change Sad
  •  
MacLab

Messages: 213
Karma: 15
Send a private message to this user
No, just make the change as mentioned in the Connect admin. But it sounds like something is blocking port 80 from working from the outside. Maybe it is just not mapped in the first place. There needs to be a rule that opens port 80 and directs it to your server.

MacLab, Inc.
Kerio Certified Partner, Reseller, Hosting Provider, Kerio Connect Certified.
http://maclaboratory.com
  •  
lodewijk

Messages: 93
Karma: 1
Send a private message to this user
no, im trying this from/in the internal LAN

as soon as I turn the option "require encrypted connection" on in security settings,

and try to connect to the webmail on port 80, i get an error in safari "can't connect Sad


..Wait, I just realised something...I have the HTTP service OFF in "Services"
Turning this on makes it all work now!!

YAY!
  •  
jan.vykoupil

Messages: 3
Karma: 0
Send a private message to this user
hm, MacLab i looked up what processes are using port 80 and 443, on both of them listens mailserver.exe, and it should be the kerio connect (accessing webmail on 443 port works), but my head cant take it why it works on 443 and not on the 80, it drives me crazy, i dont what else to do to find the solution ...

in kerio control i have both ports allowed.
Previous Topic: Do I need a new SSL Cert?
Next Topic: Samba 4 and Kerio AD Schema Extension
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Apr 25 00:45:48 CEST 2017

Total time taken to generate the page: 0.01059 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.