Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Trying to send newsletters using swiftpage [550 5.7.1 Authentication Required]
  •  
mosimo

Messages: 5
Karma: 0
Send a private message to this user
We use an e-shot mailer called swiftpage to send out newsletters to customers and internal employees. Swiftpage sends on our behalf so mail doesn't come from our server. SPF records are set up for their IPs. E-Mails are sent on my balf from my e-mail address so customers can reply and it comes to me.

Problem is when we get an e-shot to an internal (From: me@my-domain.com, To: employee<_at_>my-domain.com) I get a "Undelivered Mail" mail back to me with the error

<employee<_at_>my-domain.com : host blah blah said: 
550 5.7.1 Authentication Required (in reply to end of DATA command)


In the Kerio security logs I see:
[08/Jun/2016 17:37:43] SMTP: Message from IP address 123.123.123.123 was rejected because of missing authentication for local domain sender <me<_at_>my-domain.com>.


I have added security -> sender policy to "Never reject from IPs" with the swiftpage IPs. I'm not sure what else I need to do to allow swiftpage to send to my own domain but using my address as the from address.
  •  
Brian Carmichael (Kerio)

Messages: 559
Karma: 55
Send a private message to this user
Are you sure you have the correct IP group selected? Perhaps a few screenshots may be helpful.

Brian Carmichael
Senior Technical Marketing Engineer | Kerio
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
mosimo

Messages: 5
Karma: 0
Send a private message to this user
Image: i.imgur.com/iCM6OzZ.png
Can't link because less than 5 posts.

That is how I have my sender policy.
"Main Group" selected. All Swiftpage's IPs in "Swiftpage" group and that group in "Main Group".

Swiftpage doesn't authenticate at all to my server to send mail. It sends on my behalf and we have SPF records which are added to our domain.
  •  
j.a.duke

Messages: 337
Karma: 10
Send a private message to this user
mosimo wrote on Thu, 09 June 2016 11:25
Image: i.imgur.com/iCM6OzZ.png
Can't link because less than 5 posts.

That is how I have my sender policy.
"Main Group" selected. All Swiftpage's IPs in "Swiftpage" group and that group in "Main Group".

Swiftpage doesn't authenticate at all to my server to send mail. It sends on my behalf and we have SPF records which are added to our domain.


Are the IPs in the log file inside the Swiftpage ranges you have defined?

Also, what are your settings for relay control? It might be worthwhile to allow relay for the Swiftpage IPs (among others) there.

Cheers,
Jon
  •  
Brian Carmichael (Kerio)

Messages: 559
Karma: 55
Send a private message to this user
Your configuration is correct, although the log event from your original post shows the address of 123.123.123.123.

Brian Carmichael
Senior Technical Marketing Engineer | Kerio
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
mosimo

Messages: 5
Karma: 0
Send a private message to this user
Ok, now I feel like an idiot. I've just checked the IP again in the logs compared to the ones I have listed.
208.53.48.15 should be 208.53.48.156

Thing is that IP has been in there for roughly a year and it's been working fine until today. Changed that IP, resent the e-shot and it came through. Oh and I do have relay set to only allow for IPs "Main Group" and smtp authenticated people only.

Thanks.

[Updated on: Thu, 09 June 2016 18:10]

  •  
Carsten Maas (Kerio)

Messages: 247
Karma: 27
Send a private message to this user
mosimo wrote on Thu, 09 June 2016 18:09
Ok, now I feel like an idiot..


You don't have to. We are all humans.
Important thing is, that the users from this forum pointed you to the correct direction, how to find out what is causing the issue.

Carsten Maas
Senior Technical Marketing Engineer
Kerio Technologies

Kerio Deutschland youtube Channel
http://www.youtube.com/KerioDeutschland
Previous Topic: Active Directory users Authentication
Next Topic: KERIO APPLE KALENDER SYNC
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Dec 11 10:57:20 CET 2016

Total time taken to generate the page: 0.01177 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.