Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Outlook 365 disables add-in-----slow loading
  •  
markg2

Messages: 19
Karma: -1
Send a private message to this user
Even though I have told the 'Disabled COM Add-in' screen to 'Always enable this add-in'. And this setting does 'stick', on the 'Disabled Items' screen KoffAddin.Userinterface is disabled. I can click on same, close then go to Manage Disabled Items on the View and manage MS Office Add-ins screen, select Disabled add-ins at the bottom of the screen, click Go and the Add-ins Available screen indicates Kerio UNCHECKED. Further confusing the issue, back on the View and manage MS Office Add-ins screen, Kerio is listed under the Inactive Add-ins not Active or Disabled.

Still more confusing to me, OL sends/receives email and I just tested adding an appointment with text in the text box and all synced.

The balance of screenshots referenced are available if desired.

FYI--I had a somewhat similar problem with another syncing add-in. The developer recommended doing the following which did solve the problem:

"If you encounter an issue where the gSyncit Outlook add-in keeps being reset to inactive/disabled each time you start Outlook then take the following steps to remove the Outlook add-in settings for the current user and use the default system add-in settings".
1. Close Outlook
2. Run "regedit" from the Windows start menu
3. Locate the key " HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\AddIns\g Syncit.Connect "
4. Delete the key "gSyncit.Connect"
5. Start Outlook normally.

Can someone shed a light on this?

Mark

  •  
Pavel Dostal (Kerio)

Messages: 171
Karma: 3
Send a private message to this user
First, check in File -> Manage Add-ins (Slow and Disabled Add-Ins), that "Kerio Outlook Connector User Interface" is not disabled. You need to set it to always enabled.

Once you have add-in enabled, check that it isn't disabled again when you restart Outlook. It should stay inactive now.

We can solve that inactive status. Once Outlook made it disabled, it changed addin's load behavior again. We need to make it to load during Outlook start again. Close Outlook and run "regedit" utility to modify registry.

go to
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\K offAddIn.UserInterface
and set LoadBehavior to 3

make the same with
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\ KoffAddIn.UserInterface

It is possible that one of these keys doesn't exist on your machine. Don't try to create it, modify just the existing one.

Now you can start Outlook again. It is possible, that you will need to activate the add-in manually in Outlook, nevertheless it should stay active now even after Outlook restart.

Pavel Dostal
Kerio Technologies
  •  
markg2

Messages: 19
Karma: -1
Send a private message to this user
FYI, your 'noreply' email arrived without a link back to this thread?

Before I proceed with your instructions, I think there's a point that you missed. I will clarify to confirm your instructions do not change.

"First, check in File -> Manage Add-ins (Slow and Disabled Add-Ins), that "Kerio Outlook Connector User Interface" is not disabled"

Doing so, as you can see from my 1st screenshot, Kerio is not indicated as disabled.

However, go to File\Options\Add-ins\Com-add-ins--GO per my 2nd screenshot you see that Kerio is unchecked. This is the screen that regardless of what I do, the screen will return upon request unchecked again. Yet, again I state, the screen to which you refer per my 1st screenshot will still not indicate Kerio as disabled.

This is the seeming paradoxical manner in which OL is handling your module.

Mark

  •  
Pavel Dostal (Kerio)

Messages: 171
Karma: 3
Send a private message to this user
Unchecked addins in screenshot "Com Add-ins_2.PNG" are "inactive". Such addins hasn't been started (or has been stopped) and it is most likely caused by the load behavior, that can be modified by the steps from my post. You can start/stop them by checking/unchecking in the COM Add-ins menu, nevertheless restarting the Outlook returns them to the state according to LoadBehavior in the registry. BTW, you can see add-in load behavior in Outlook, however you can't change it.

On the other hand disabled items were marked by Outlook itself (or theoretically by user in registry). I don't think you can start them until you enable them. It is the reason why I asked to enable the add-in first. If the add-in is not in Disabled Add-Ins, continue directly to registry changes.

Pavel Dostal
Kerio Technologies
Previous Topic: Calendar won't update from Android phone - Using Touchdown HD email app
Next Topic: new Kerio Antispam is it reliable?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Dec 09 16:20:30 CET 2016

Total time taken to generate the page: 0.01863 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.