Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Problem with Public Contacts Folder
  •  
bogomil22

Messages: 15
Karma: 0
Send a private message to this user
Hello,
i have a problem with the public contacts folder (we actually don't use them anyway). Kerio v9.0.3:

In the kerio connect error log i always get these constantly :

folder_manager.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
Last message repeated 8 times


After upgrade to 9.2.0:

GalContact.cpp: Cannot loaded user UserA<_at_>mydomain.local for domain mydomain.local from GAL: Failed to open GAL folder

GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts


What can i do to remove that error? As i said we actually don't use public contacts. We i just delete the public contacts folder? Maybe a bad idea...
The problem just appears a long time ago, but as far as i know we did nothing special.



-----
Second: a question:
After updating kerio connect to 9.2.0 and apple devices to iOS 10.1 i checked the "mobile devices" for this user and kerio is still using "EAS 14.1" (ActiveSync) and not the newest one v16.1 or at least v16.0 (which is supported by apple since iOS 9).
How can i switch in kerio to EAS 16.0 or 16.1 with my iOS 10.1 devices? I don't miss any feature right now, but i guess software is an ongoing development (bug fixes etc) so that nothing speaks against to upgrading from EAS 14 to 16.0. Just one advantage from 16.0 is the enhanced calendar reliability. Just asking.

Thanks

[Updated on: Sun, 06 November 2016 08:42]

  •  
bogomil22

Messages: 15
Karma: 0
Send a private message to this user
Can someone help me with that error message?
(And maybe answer my second question too)

much thanks
  •  
bogomil22

Messages: 15
Karma: 0
Send a private message to this user
I still getting the errors. Any solutions? Please
  •  
Carsten Maas (Kerio)

Messages: 247
Karma: 27
Send a private message to this user
If nobody answers your question, I would recommend to open a ticket with our support:

http://www.kerio.com/support

Carsten Maas
Senior Technical Marketing Engineer
Kerio Technologies

Kerio Deutschland youtube Channel
http://www.youtube.com/KerioDeutschland
  •  
b-tom

Messages: 177
Karma: 4
Send a private message to this user
Issue 1 - Public Folder.
a) You may try to uncheck and re-enable the checkbox for Publish in Global Adress List (GAL) in the Users settings. Login in Kerio Connect Webmail Client.
b) Also, try restarting Kerio Connect Server

EAS:
As far as I remember there has been already a thread about this. Accordingly to the Release Notes, ActiveSync 14.1 is the latest version which is shipped with KC9. Support for Exchange ActiveSync 14.1 has been added with Version 8.5.0 - May 18, 2015
  •  
bogomil22

Messages: 15
Karma: 0
Send a private message to this user
b-tom wrote on Thu, 01 December 2016 23:04
Issue 1 - Public Folder.
a) You may try to uncheck and re-enable the checkbox for Publish in Global Adress List (GAL) in the Users settings. Login in Kerio Connect Webmail Client.
b) Also, try restarting Kerio Connect Server

EAS:
As far as I remember there has been already a thread about this. Accordingly to the Release Notes, ActiveSync 14.1 is the latest version which is shipped with KC9. Support for Exchange ActiveSync 14.1 has been added with Version 8.5.0 - May 18, 2015


Thanks. I tried (a) and (b). I disabled on all users the Global Adress listing, but the problem isn't solved by that. Only the error log file changed a bit.

Before the change i got an error for every user:

[04/Dec/2016 10:03:23] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 10:51:23] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 10:51:23] GalContact.cpp: Cannot loaded user USER_A<_at_>mydomain.local for domain mydomain.local from GAL: Failed to open GAL folder
[04/Dec/2016 10:51:28] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 10:51:28] GalContact.cpp: Cannot loaded user USER_B<_at_>mydomain.local for domain mydomain.local from GAL: Failed to open GAL folder
[04/Dec/2016 10:51:33] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 10:51:33] GalContact.cpp: Cannot loaded user USER_C<_at_>mydomain.local for domain mydomain.local from GAL: Failed to open GALfolder


After the change:

[04/Dec/2016 11:03:24] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 12:03:25] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 13:03:26] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 14:03:27] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 15:03:28] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 16:03:29] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts
[04/Dec/2016 17:03:30] GalFolder.cpp: Cannot open contact public folder #public<_at_>mydomain.local/Contacts


You see that the error occurs very one hour.
Because we don't use Global Contacts.. can i delete the public folder (C:/Kerio/Email/mydomain.local/#public/Contacts) ??. The #msgs folder under public Contacts is empty - in the Contacts folder are just .fld and .dbb files

[Updated on: Mon, 05 December 2016 10:53]

  •  
core

Messages: 12
Karma: 0
Send a private message to this user
Hi,

I have the exact same problem with many errors repeating in logs, for every user.

GalFolder.cpp: Cannot open contact public folder #public<_at_>domain.com/Contacts

Plus, we also have this:

GalContact.cpp: Cannot store user user<_at_>domain.com for domain domain.com in GAL: Failed to open GAL folder

GalContact.cpp: Cannot loaded user user<_at_>domain.com for domain domain.com in GAL: Failed to open GAL folder


Is there any way to fix this?
  •  
tera

Messages: 1
Karma: 0
Send a private message to this user
Hello everyone,
I have the same issue and no clues to solve this annoying error in log.

GalFolder.cpp: Cannot open contact public folder #public<_at_>domain.xxx/Contacts

Thank you for your help.
  •  
core

Messages: 12
Karma: 0
Send a private message to this user
..is there any way to get rid of these error logs?
Thanks
Previous Topic: BUG: IMAP sends \HasNoChildren in 9.2.2
Next Topic: (BDANTISPAM_ERROR_CLOUD_NO_RESPONSE)
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 03:15:03 CEST 2017

Total time taken to generate the page: 0.00436 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.