Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » XMPP processes even though services are disabled (XMPP processes are running (or started) even though the XMPP services have been disabled)
  •  
lgsit

Messages: 18
Karma: 0
Send a private message to this user
Hello,

I'm using Kerio Connect 9.2.1 (the current version so far) and just noticed that the memory usage on my Kerio Connect server is pretty high after starting the Kerio Connect service.

I checked via htop and noticed processes that seem to be related to XMPP (the following line was taken from ps aux, but the processes listed inside htop are similar):

javaservices/jre/bin/java -Djava.net.preferIPv4Stack=true -Xmx256m -XX:ErrorFile=core-xmppserver.dmp -jar javaservices/xmppserver/service-im.jar service.dir=javaservices/xmppserver data.dir="/var/mail/xmpp" log.debug=0 service.im.timeout=180 service.im.remote.domain=kerio-connect.private service.im.remote.login=engine-im service.im.remote.port=4042 roster.maximum=300

I can see that those consume quite some memory.

I'm wondering why these processes are running (or even started), because inside the web admin interface the XMPP services have been disabled (stopped and set start-up to "manual") and the "Enable chat inside Kerio Connect client" (or similar) on the "General" tab of the domain configuration is also unchecked.

Of course I restarted the Kerio Connect service after changing those settings (even the whole system), but these processes still appear, but why and how can I get rid of them?

Thanks in advance!
  •  
Radek Sip (Kerio)

Messages: 1319
Karma: 48
Send a private message to this user
If the XMPP(S) services are disabled and the instant messaging server is not accepting client connections, it's still running as the part of mailserver and it's accepting the admin connections. It consumes 256MB RAM, if it's performance problem on your server, you can disable it in mailserver.cfg (while Kerio Connect is stopped):
<table name="InstantMessaging">
...
<variable name="Enabled">0</variable>
...


It's on your own risk and do not forget to enable it in the future when IM will fail to start Smile

Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
lgsit

Messages: 18
Karma: 0
Send a private message to this user
Okay, I have set Enabled to 0 as well as the IsInstantMessagingEnabled in the domains, saved and restarted.

There are way less processes left, but there still are 21 of them (before there were 50 or something like that). The memory usage decreased a little bit, but not significantly.

Do I have to change another thing?
Previous Topic: Require phone passcode
Next Topic: Get email addresses from Kerio using LDAP
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed May 24 00:29:56 CEST 2017

Total time taken to generate the page: 0.00948 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.