Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Outlook Mac 2016 and Kerio 8.5.3 on Sierra - inbox not complete (Outlook inbox not complete though sync status shows complete)
  •  
vrlpete

Messages: 4
Karma: 0
Send a private message to this user
I have an issue with Outlook 2016 for Mac (build 15.30) running on macOS 10.12.1, connecting to Kerio Connect 8.5.3.

Having upgraded the mail server to enable Outlook 2016 for Mac on Sierra to connect to it, I've gone through the configuration of the client using the Kerio Connect Assistant., configuring it for my mail account. (I have Outlook 2011 running fine on another machine and this is displaying and syncing fine.)

All configured fine, I launch Outlook and the inbox and sub-folders start to appear. All the sub-folders seem to be populating fine (Sync Status shows them updating and the contents are O, but...

...even though Outlook states the inbox is up-to-date, it is only displaying emails as new as 2 years ago (17th Feb 2015 is the newest email).

I have tried deleting the account in Outlook and running the Kerio Assistant again - same result.
I've manually created an Exchange account in Outlook (non-autodiscover) - same result.

According to Outlooks Sync Errors tool...there are none
There is nothing to indicate problems when viewing the logs in the Kerio backend.

Any ideas on a) what's causing this and b) how to solve it, short of upgrading Kerio Connect again - I'm reluctant to do this due to having some older Macs with olders versions of OS and Outlook 2011 Mac running.
  •  
vrlpete

Messages: 4
Karma: 0
Send a private message to this user
A quick update on further tests.

Configured Mail.app via Kerio Assistant and this 'seems' to be syncing fine (the inbox in certainly up-to-date), so the issue seems to be to do with the Exchange setup in Outlook 2016.
  •  
Pavel Špalek (Kerio)

Messages: 287
Karma: 37
Send a private message to this user
Please enable logging in Outlook for Mac and send me the log in the private message (upload to the cloud and send the link). There was a bug in XML parsing on Outlook side, it failed on some specific UTF-8 character. This bug could cause such behavior, it's already fixed in recent Connect versions (I believe since 9.x).

Pavel Špalek
developer - Kerio Connect
  •  
vrlpete

Messages: 4
Karma: 0
Send a private message to this user
Thanks Pavel....I've done as you've asked...please let me know the outcome.
  •  
Pavel Špalek (Kerio)

Messages: 287
Karma: 37
Send a private message to this user
I can confirm this is the XML parsing bug, it can be identified by the message
PCDATA invalid Char value

in the Outlook log. It's caused by unprintable ASCII character in message header, in this case the character with ASCII code 0x0031.
This problem is fixed since Connect v. 9.0.0 so either upgrade or you can delete the invalid message, unfortunately I'm not able to identify it, Outlook log doesn't contain the whole requests. It should be one of the next 512 unsynchronized messages in Inbox (sorted by delivery time; Outlook synchronizes in batches of 512 messages), probably it will contain some strange character in Subject.

Pavel Špalek
developer - Kerio Connect
  •  
vrlpete

Messages: 4
Karma: 0
Send a private message to this user
Thank you for the information. I will look to upgrade the mail server to at least 9.0.x and see what happens.

This seems the better way of doing things rather looking for the invalid char in the subject field.
Previous Topic: Sharing calendars across domains
Next Topic: Schedule of housekeeping activies
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon May 22 23:35:55 CEST 2017

Total time taken to generate the page: 0.02059 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.