Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Error 1911 When Installing / Upgrading Outlook Connector
  •  
NorthernAlberta

Messages: 54
Karma: 6
Send a private message to this user
Hi folks,

Has anyone else been struggling with the following error when installing or upgrading the Outlook Connector?

"Error 1911. Could not register type library for file C:\Program Files (x86)\Kerio\Outlook Connector (Offline Edition)\KoffAddin.dll. Contact your support personnel."

I first encountered this back in 2015 when I tried to upgrade the KOFF on my Windows Server 2008 terminal server. Back then I worked with Kerio support and they had me uninstall Microsoft patch KB3072630, complete the upgrade, then repatch. It's 2017 now and that solution no longer appears to work.

I've spent several days on my own trying to track this problem down. It looks like it was quite common back in 2015 with many companies being affected (Adobe, QuickBooks/Intuit, SolidWorks, etc.) but I haven't seen any current reports.

There are a wide range of solutions online, most no longer seem to work (if they ever did). These include uninstalling different patches, registry hacks to disable protection, and creating whitelists.

The only solution I've found is to use Sysinternals' program 'psexec'. This program is intended to run commands on remote computers, but has the additional option to execute commands under the SYSTEM account. Doing this appears to allow the .msi package to complete successfully.

psexec can't run msi files directly (they have to be run via msiexec) so I've created a batch files to perform the installation, and then use psexec to call it. Doing this all on the local computer brings the Kerio install GUI up normally.

I've yet to run this in production but my quick tests appear to be successful, at least for the installation step.

I'm a little concerned running an install under SYSTEM, as well as what effect this may have in my multi-user environment as I'm currently not calling Install Mode.

My real question at the end of it all: Is this the best way to do this? And am I unique in having this problem to begin with? It seems to be specific to terminal servers, and the KOC package is the only one I've ever had this issue with.




Example command: psexec -i -s c:\InstallKOC.bat
(Calls psexec to run a command on the local computer, -i allows it to interact with my desktop, and -s runs it under the SYSTEM account.)

InstallKOC.bat: msiexec /i "c:\kerio-connect-koff-9.2.1-2397-win32.msi"
(Use the msiexec program and /i to install the Kerio file. Even if this is an upgrade we're still 'installing' it.)
Previous Topic: Important update about antivirus in Kerio Connect 9.1.1 and earlier on Mac
Next Topic: Existing Outlook accounts removed when using autoconfig tool
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Sep 26 12:57:44 CEST 2017

Total time taken to generate the page: 0.00302 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.