Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » IMAP access to server (Delay in the availability of new messages read via IMAP)
  •  
andrea.giovannini

Messages: 1
Karma: 0
Send a private message to this user
Hi,
I have a problem with a Java application that accesses via IMAP a mailbox in a Kerio server.
The application checks periodically if there are unread messages in the mailbox: it processes every message and then marks it as read.
Sometimes there is this strange behaviour:
- a new message arrives in the mailbox (I can see it in the KerioConnect Web Interface)
- after a few minutes the application checks the mailbox but doesn't find any new message
- after a while (about 30 minutes) the application finds the new message and processes it.

This is the log of the communication between the Java application and the mail server when the application doesn't find the already arrived message:

...
DEBUG: setDebug: JavaMail version 1.4ea
DEBUG: getProvider() returning javax.mail.Provider[STORE,imaps,com.sun.mail.imap.IMAPSSLStore,Sun Microsystems, Inc]
DEBUG: mail.imap.fetchsize: 16384
* OK Kerio Connect 9.2.1 IMAP4rev1 server ready
A0 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 IDLE ACL LITERAL+ UIDPLUS QUOTA ID SORT ANNOTATE ANNOTATEMORE STATUS-COUNTERS UNSELECT LISTEXT NAMESPACE XLIST SPECIAL-
USE XAPPLEPUSHSERVICE AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN AUTH=DIGEST-MD5 AUTH=NTLM
A0 OK CAPABILITY completed
IMAP DEBUG: AUTH: CRAM-MD5
IMAP DEBUG: AUTH: PLAIN
IMAP DEBUG: AUTH: LOGIN
IMAP DEBUG: AUTH: DIGEST-MD5
IMAP DEBUG: AUTH: NTLM
DEBUG: protocolConnect login, host=email.server.ip.address, user=user<_at_>my.test, password=<non-null>
A1 AUTHENTICATE PLAIN
+
...........long_alphanumeric_string.......................................................==
A1 OK Authentication successful
DEBUG: connection available -- size: 1
A2 SELECT INBOX
* FLAGS (\Deleted \Seen \Answered \Draft \Flagged $MDNSent $Forwarded $AutoJunk $AutoNotJunk $Junk $NotJunk)
* 1 EXISTS
* 0 RECENT
* OK [UNSEEN 1] Message 1 is first unseen
* OK [UIDVALIDITY 1476264859] UID validity
* OK [UIDNEXT 103] Predicted next UID
* OK [PERMANENTFLAGS (\Deleted \Seen \Answered \Draft \Flagged $MDNSent $Forwarded $AutoJunk $AutoNotJunk $Junk $NotJunk)] Permanent flags
A2 OK [READ-WRITE] SELECT completed
A3 SEARCH UNSEEN ALL
* SEARCH
A3 OK SEARCH completed in 0.00 s
A4 EXAMINE INBOX
...


when the application finds the message the log is identical except the last three lines:

...
* SEARCH 1
A3 OK SEARCH completed in 0.00 s
A4 FETCH 1 (ENVELOPE INTERNALDATE RFC822.SIZE BODYSTRUCTURE)
...


It seems like the Kerio server sometimes needs more time to make the mail message available through IMAP.
In other situations the applications finds new messages the first time it checks the mailbox after they arrive.

Does anybody have an idea about this behaviour?
Is this a possible problem or it should be considered correct?

Thanks in advance.

Regards,
Andrea


Previous Topic: LDAP Authentication vs. OpenDirectory Password Server
Next Topic: Changing the user's profile color
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon May 29 07:53:30 CEST 2017

Total time taken to generate the page: 0.00914 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.