Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » DKIM signing for unauthenticated SMTP? (DKIM signing for unauthenticated SMTP)
  •  
_Jim_

Messages: 2
Karma: 0
Send a private message to this user
Hello,

We use Kerio Connect as an SMTP relay for internally-hosted applications (two separate Kerio Connect servers which are load-balanced). In other words, we don't configure user accounts on the Kerio Connect servers, but instead use the SMTP relay functionality.

We have a need for DKIM signing on our application e-mail. I've configured DKIM on one of the domains (as well as in public DNS), and it works fine, but only if I send a message using authentication with a user account defined inside of Kerio Connect. Messages received via unauthenticated SMTP aren't signed.

I can understand the "why" on this (you probably wouldn't want a midtream SMTP relay signing messages), but I'm wondering if it's possible to enable it on the KC server for messages received from clients via unauthenticated SMTP. Otherwise, we'd need to either have our applications sign the messages themselves, or authenticate against Kerio Connect. I'm not sure if either of the latter are possible at this point, but I'm chasing those, too.

Our Kerio Connect version is old (8.3.2), in case that is relevant.

Thanks for any help!

Jim
  •  
freakinvibe

Messages: 1488
Karma: 57
Send a private message to this user
This works for us. You must host the domain on your Kerio server, otherwise it does not work. Just don't create any users for that domain on KC. Then configure it to forward the mails, if a local user is not found. This works for us.

Dexion AG - The Blackberry Specialists in Switzerland
http://www.dexionag.ch
  •  
_Jim_

Messages: 2
Karma: 0
Send a private message to this user
Thank you freakinvibe, I can confirm that it is indeed working as you describe.

I found that when the destination e-mail domain was also defined on KC with a forwarder, and that domain not configured with DKIM, the messages were not signed. I removed that domain from KC (instead using global forwarding) and that resolved it.

[Updated on: Tue, 16 May 2017 19:27]

Previous Topic: Unable to synchronize a message with outlook 365
Next Topic: Archive public folders
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon May 29 04:00:06 CEST 2017

Total time taken to generate the page: 0.01064 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.