Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Kerio Control 9.2 - wrong port mapping for 3cx PBX
  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Hello, there is a Kerio Control with Internet Ipv4 Static IP, and 3CX in local network, using this guide in Kerio is set port mapping for 3CX, but when I check firewall using 3CX utility - it reports me an error, also - I have problems with incoming calls - I can't hear other side.
I called to 3CX support - they collect some log information from PBX and said that the reason in Kerio.
When I use port checker from BPX - it says that error:

stopping service... done
testing port 5060... failed
testing port 5060... unmatched mapping (62754)
starting service... done

- Hot to resolve the problem ?

[Updated on: Mon, 03 July 2017 13:51]

  •  
Brian (GFI/Kerio)

Messages: 742
Karma: 71
Send a private message to this user
Have you disabled protocol inspection for SIP? Normally this should be enabled. Unfortunately it's difficult to guess the problem without access to your configuration. Please contact our technical support.

Brian Carmichael
Instructional Content Architect
  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Quote:

Have you disabled protocol inspection for SIP?

Yes, but I have enabled it, there was no result
I can provide you with configuration (backup). I think that this forum is official Kerio forum and support. Can anyone help me with problem ?
  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Addition: I've restartek Kerio and port check for 5060 is done, but there are errors in port check for UDP 9000-9500:

testing port 9061... unmatched mapping (50905)
testing port 9109... unmatched mapping (47665)

If I restart Kerio, the problem is off for some time but then the problem is back again, but port 9xxx with errors differ.
What's the cause of the problem ?
  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Addition: in 30 minutes, now the problem is gone. But after some time - it will come back again
  •  
Brian (GFI/Kerio)

Messages: 742
Karma: 71
Send a private message to this user
Have you tried creating an inbound rule to map those UDP ports 9000-9500 to your PBX? Otherwise, you may see if it's possible to increase the frequency of the SIP registration on your PBX.

Brian Carmichael
Instructional Content Architect
  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Brian Carmichael (Kerio) wrote on Tue, 04 July 2017 19:47
Have you tried creating an inbound rule to map those UDP ports 9000-9500 to your PBX? Otherwise, you may see if it's possible to increase the frequency of the SIP registration on your PBX.

- Yes, of course.
Last week I restarted Kerio and problem is gone. I thought that it was a single problem (some bug), but today the problem arose again, I've restarted Kerio and the problem is gone again. The reason is Kerio!
I think there are some bugs in Kerio. Please help me to resolve the problem. What should I do next time when the problem will arise ? How can I "catch" it ? May be I should change some configuration in Kerio ? I can send Kerio official representative backup of my Kerio configuration. Let's solve this problem.

Below are services and port mapping in Kerio for 3CX PBX:
http://s015.radikal.ru/i331/1707/b1/66fe85e3efbe.jpg

http://s018.radikal.ru/i522/1707/cc/6b56bdd181f3.jpg

http://i066.radikal.ru/1707/df/bf40225ed98c.jpg

  •  
__guest__

Messages: 20
Karma: 0
Send a private message to this user
Any ideas ?
On today the problem is: with incoming call - call breaks after 5 or 6 seconds, and then with outcoming calls - there is just silence.
  •  
Brian (GFI/Kerio)

Messages: 742
Karma: 71
Send a private message to this user
You should not apply any protocol inspector to your custom port range of 9000 to 9500. If you need further assistance please open a request with our technical support team. https://www.gfi.com/support/kerio-support

Brian Carmichael
Instructional Content Architect
  •  
PPG

Messages: 73
Karma: 4
Send a private message to this user
I've added an image of my VOIP setup (Kerio Operator), hope it helps.

  • Attachment: clip.PNG
    (Size: 26.53KB, Downloaded 17 times)
Previous Topic: no streaming on facebook using vmix 17
Next Topic: Block remote access (LogMeIn, GoToMyPC, etc)
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Sep 24 03:30:02 CEST 2017

Total time taken to generate the page: 0.00580 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.