Home » Kerio User Forums » Kerio Connect » SMTP won't start - port 25 already in use - Stock KC VM appliance (After update of KC virtual machine SMTP fails to run)
  •  
oregonbob

Messages: 11
Karma: 0
Send a private message to this user
I just D/L the latest Kerio Connect Virtual appliance, installation and restore data went OK.

Version: 9.2.5 patch 3 (3336)
Operating system:
Debian GNU/Linux 8.9 (Kerio VA), x86_64

The SMTP service won't run, shows error:

[27/Mar/2018 15:13:58] KSocket.cpp: Bind to port 25 failed: (98) Address already in use
[27/Mar/2018 15:13:58] ProtocolServiceDerives.cpp: Cannot start service SMTP on port 25, unable to bind service to all addresses
[27/Mar/2018 15:13:58] ProtocolService.cpp: Service SMTP failed to start
[27/Mar/2018 15:15:20] KSocket.cpp: Bind to port 25 failed: (98) Address already in use
[27/Mar/2018 15:15:20] ProtocolServiceDerives.cpp: Cannot start service SMTP on port 25, unable to bind service to all addresses
[27/Mar/2018 15:15:20] ProtocolService.cpp: Service SMTP failed to start

This is a stock VM just as Kerio offers, so I don't know why another program would be on port 25.

Update: netstat shows exim4 package is listening on port 25. It appears kerio accidentally included the exim4 package in their virtual appliance. How should I either configure or remove exim4 to get Kerio Connect working?

[Updated on: Wed, 28 March 2018 03:15]

  •  
j.a.duke

Messages: 186
Karma: 14
Send a private message to this user
Welcome to the GFI era....

Just a quick search for "how to uninstall exim on debian":

https://www.linuxquestions.org/questions/debian-26/remove-ex im4-completely-651312/

http://forums.debian.net/viewtopic.php?t=64475

Just a couple of hits out of many.

Cheers,
Jon
  •  
oregonbob

Messages: 11
Karma: 0
Send a private message to this user
I figured this out. I simply removed the exim4 package that is on the stock appliance. I guess Kerio don't test their appliances so I had to spend hours figuring out what went wrong.

This command fixed it:

sudo apt-get remove exim4-base

Then Kerio started working!

Kerio: Please remove that pesky exim4 mail package from your virtual appliance.

[Updated on: Wed, 28 March 2018 03:35]

  •  
wag357

Messages: 47
Karma: 8
Send a private message to this user
No Message Body

[Updated on: Wed, 28 March 2018 21:26]

  •  
oregonbob

Messages: 11
Karma: 0
Send a private message to this user
Kerio is so screwed up. I just got an email from wag357 that says:
"I'm showing 9.2.6 available for download. Is it really 9.2.5 p3?"

I clicked "Reply" and got a "Kerio System Error" page. So I clicked link to inform webmaster and it was a dead link.

Then I tried to click "View thread" and it just took me to the Forum front page, not this thread. Things are looking real amateurish.

I D/L the VM on 3/26/18 and there was no 9.2.6 available. So if it says that it is something new.

[Updated on: Wed, 28 March 2018 21:36]

  •  
phil68

Messages: 14
Karma: 2
Send a private message to this user
Installed latest VM with 9.2.6 - still needed to uninstall exim, this is just ridiculous...
Previous Topic: Kerio Setup Assistant not working in High Sierra (10.13)
Next Topic: EWS Support
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Oct 19 19:11:30 CEST 2018

Total time taken to generate the page: 0.74447 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.