Home » Kerio User Forums » Kerio Connect » Kerio 9.2.6 Kerio Offline Connector CRASHES -> Solution
  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
As described in http://forums.kerio.com/t/33380//13029/488d7864ed36fa65f69b0 fafc95d649a/ , the 9.2.6 (3807) version comes with a defective KOFF Connector, which keeps Outlook from starting and pops a message windows.

(My) Solution:

- Download the most recent server version 9.2.6 (3811) from https://www.kerio.com/content/kerio-connect-download and install it on the server.

- On the client: start Outlook so that the automatic KOFF upgrade triggers (Outlook will close as usual during that process). This will install KOFF Connector 9.2.6 (3811).

- A start of Outlook after the update will show a much more informative error and tell you to erase the local cache.

- Erase the cache: the video https://www.youtube.com/watch?v=NYHebBGMwVg shows this on Windows XP and in Italian (I think), the process however is very similar on Windows 10:
*Press the start button -> search for "Control Panel" (Desktop App), that would be the old control panel you know from Windows 7.
* start "E-Mail (32-Bit)"
* On the new panel: "Email-Accounts..." (the first button from the top)
* Tab "E-Mail": double click the account with (KOC Offline....) behind it.
* The Kerio Outlook Connector Panel opens: go to tab Maintenance and empty the cache there.

- Restart Outlook. It should start now together with the KOFF Connector and show the "first sync" message (just like adding a new computer/OL installation to an existing mailbox). It will re-populate all data after that, just let it run.

- After minutes up to hours, depending on how big the mailbox is, everything will be back to normal.

[Updated on: Wed, 28 March 2018 21:41]

  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
Please comment if you still have problems. I am hopeful that this fixes issues for all versions of Outlook.
  •  
JohnD

Messages: 30
Karma: 4
Send a private message to this user
Outlook 2016 starts, but crashes. You get the box from Kerio saying it crashed and it offers to send the error to Kerio. This is on 9.2.6-3811

  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
Did you clear the cache? Without doing that, OL will always crash.

I did this on OL 2013.
  •  
JohnD

Messages: 30
Karma: 4
Send a private message to this user
From others comments that I've read today, 2013 does indeed work with clearing the cache, but not 2016. I did clear the cache though. Outlook does then indeed start, but the Kerio connector will crash. It doesn't kick you out of Outlook, but the Kerio connector disappears from your system tray and you are presented with the Kerio crashed box.
  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
Then Kerio still has quite some work to do and push another server/client version which fixes OL2016.

I can't remember something like this happening before GFI...
  •  
Jens Osterwohldt

Messages: 56
Karma: 9
Send a private message to this user
I use KOFF 9.2.6-3811 with Outlook 2016 and it works well after cleaning the cache.

We are specialists for migrations from AVM KEN! 4 and David from Tobit.Software to Kerio Connect.
  •  
jr

Messages: 1
Karma: 1
Send a private message to this user
And how do you handle clearing the local cache of hunderts of roaming users?
  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
jr wrote on Thu, 29 March 2018 10:55
And how do you handle clearing the local cache of hunderts of roaming users?


That is indeed the major problem! I have a quite small installation, so I can assist personally. That should not be doable with hundreds of users. That is why I don't understand that Kerio is not reacting AT ALL. At least an email to the registered server administrators would have been necessary. Or some comment here or somewhere else. Or some assistance (like I am trying to give).
  •  
Lionel Hutts

Messages: 15
Karma: -1
Send a private message to this user
You could disable the automatic KOFF Update then use a batch script to delete "%localappdata%\Kerio\Outlook Connector\Outlook*" folder and finally update KOFF through GPO.
  •  
ferro

Messages: 18
Karma: 0
Send a private message to this user
Hi all,

After following the above recommended solution for the defective KOFF connector (clearing cache), outlook worked just fine. However as soon as it was restarted, the problem came back as before and the same failure appeared!

The solution that I am currently thinking of is to downgrade to previous version of even Kerio connect 9.0, what is the best way to do that? Do I have to reinstall version 9.0 and migrate everything or is there a faster and more effective solution?

Thanks,

Thanks,
  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
As Kerio has acknowledged in their forum statement, that there are still problems with OL2016, I would hope they are still working on a better fix than 3811, so I would not react too hastily and hope for an (obligatory!) fix next week.
  •  
ferro

Messages: 18
Karma: 0
Send a private message to this user
Hi Thunderbyte and all,

In fact the problem appears with OL2010 clients even after applying the cache clearing solutions. As I mentioned before, the cache clearing solution works as long as OL2010 is not started, once it stats, everything is back to the same problem again!

I need support in:
1- Will build 3811 address this problem? If so where is a download link to this build as I cannot find it?
2- Will downgrading to a lower version of kerio be a better temporary solution? What is the most effective way to do so?

Thanks,

Thanks,
  •  
Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
Hi ferro,
1- the problem emerged from buggy/defective KOFF builds 9.2.6 (3807 and 3809), which were installed automatically after installing the corresponding server version (you certainly know the KOFF update procedure after server upgrades), in my case via the update function in the admin interface. Those two versions might have been available via the Kerio DL website as well.
You need to bring the client version to 3811 which is simply done by downloading the most recent 3811 server version via http://www.kerio.com/support/kerio-connect , which only shows 9.2.6 as version number. Right now, this however is 3811 (and might be an even newer build without changing the version number in the near future).
2- If you don't have installed 9.2.6, DO NOT DO IT. I honestly don't know if a downgrade works, because I have never done it. The build 3811 has fixed some of the problems of those with the mentioned buggy versions, so that would be the way forward for those. For all others: do not install 9.2.6.

[Updated on: Sat, 31 March 2018 15:47]

Thunderbyte

Messages: 38
Karma: 5
Send a private message to this user
No idea if you think this is proper English. Well, it isn't.

And I am paying for Kerio software maintenance. Therefore I expect proper testing before releases, quick bug fixes and ommunication with customers. All of those are lacking here.
Previous Topic: Index error
Next Topic: NDR Emails Outlook vs. Kerio Connect WEBMAIL
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Nov 20 09:00:44 CET 2018

Total time taken to generate the page: 0.80561 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.