Home » Kerio User Forums » Kerio Connect » 9.2.6 build 3811 - Faulting module name: MSVCR100.dll (Kerio Connect 9.2.6 crashes)
  •  
bram06

Messages: 12
Karma: 0
Send a private message to this user
So one thing I forgot to mention was I deleted the instant messenger database which cleared up the mailbox messages but I went ahead and disabled the service anyways. I think those messages we are seeing are for instant messaging. I reindexed each user folder afterwards and it found no corrupt folders. Also I'm using Ubuntu.
  •  
wag357

Messages: 50
Karma: 8
Send a private message to this user
I'm having more frequent issues this morning.
I edited the CFG file and found XMPP was set to 1 eventhough I've had it disabled for months. I stopped the mailserver service, changed the 1 to a 0 and when I restarted, the log showed XMPP starting up anyway.
While the server was down, I renamed the MSVCR100.dll and copied in an older version DLL. Probably dangerous, but worth a try. I'll report back.

[Updated on: Mon, 09 April 2018 16:28]

  •  
SBMT

Messages: 33
Karma: 0
Send a private message to this user
wag357, go back to 9.2.5p3... it's safer!!!
  •  
wag357

Messages: 50
Karma: 8
Send a private message to this user
So far, things seemed to have calmed down. I'm not seeing corrupt folders and the service has stayed running. *fingers crossed*

The logs have been clean except for:
[09/Apr/2018 10:53:19] Spamassassin Bayes database cleanup has blocked external server.
[09/Apr/2018 10:59:24] SpamAssassin AWL database cleanup has blocked external server.

which may not be related.
  •  
wag357

Messages: 50
Karma: 8
Send a private message to this user
Just following up.
Almost 24 hours later and still no more serious issues.
  •  
Konji

Messages: 6
Karma: 1
Send a private message to this user
Allegedly disabling av from web admin panel helps with 9.2.6 build 3811 crashes. Worth testing as it takes 30sec. to change settings.
  •  
dzjowk

Messages: 5
Karma: 0
Send a private message to this user
I can state that disabling AV will not solve the problem. As we (with build 3811) have been experiencing crashes up to every 10 minutes, and AV was never enabled.

Crashes seem to coincide with x509 certificate operations :
[06/Apr/2018 14:52:02] cert_mgr.cpp: Cannot set SSL private key for server connections: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch.
[06/Apr/2018 15:07:09] cert_mgr.cpp: Cannot set SSL private key for server connections: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch.
[06/Apr/2018 15:21:19] cert_mgr.cpp: Cannot set SSL private key for server connections: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch.

Last update on a new build to be released to fix the issues dates back to 2018-03-29.
Dear support, when will we receive an update ?
  •  
wag357

Messages: 50
Karma: 8
Send a private message to this user
48 hours later and the only issues being reported are a few mobile users have been asked to reenter their password by their mobile mail app. Whether Outlook for Android/iOS or the iOS built-in mail app. This may not even be related, but I wanted to put all the info I have out here.

[Updated on: Wed, 11 April 2018 23:04]

  •  
Chris68

Messages: 2
Karma: 0
Send a private message to this user
Had exactly the same problems ...

Turn on ActiveSync in debug mode - you will see it allways crashes at the same user trying to sync!!! Most likely this will be a Windows 10 Mail-App User (and pretty sure that this user has drafts in this app trying to sync)

We just deleted this MailApp account and gave that user a Outlook to work with. Problem solved!
  •  
qElijahq

Messages: 5
Karma: 0
Send a private message to this user
I just had to create a quick batch file(I know...I'm old) to start the Kerio mail service every 10 seconds. Sloppy way to do it, but maybe it will hold me until they decide to release a patch.
  •  
Chris68

Messages: 2
Karma: 0
Send a private message to this user
Dear qElijahq ... why not just just use service characteristics and make it start once it fails ... But - that will still mean trouble for your users being disconected every whatsoever...
  •  
qElijahq

Messages: 5
Karma: 0
Send a private message to this user
Just telling it to restart automatically as a service is the default behavior anyway, but doesn't work.
  •  
wag357

Messages: 50
Karma: 8
Send a private message to this user
Has anyone else tried replacing their MSVCR100.DLL as I have? I've been running with no issues for a couple of days but without others corroborating my findings I'm not sure my fix is actually what put a band-aid on my issues.

I simply stopped the mailserver service, found another MSVCR100.DLL on the box, renamed the original in the mailserver directory, pasted in the older copy and started the service again.
  •  
Maerad

Messages: 210
Karma: 38
Send a private message to this user
wag357 wrote on Fri, 13 April 2018 16:48
Has anyone else tried replacing their MSVCR100.DLL as I have? I've been running with no issues for a couple of days but without others corroborating my findings I'm not sure my fix is actually what put a band-aid on my issues.

I simply stopped the mailserver service, found another MSVCR100.DLL on the box, renamed the original in the mailserver directory, pasted in the older copy and started the service again.


Yeah, I already did the same. Downloaded the lastest 2010 C++ Runtime SP1 from Microsoft and extracted the files. Now I changed them. I'll report back, if I still get the application hangs or if it's better now.
Maerad

Messages: 210
Karma: 38
Send a private message to this user
Update - changed the files, nothing happend. Kerio still crashed several times and I had to downgrade. First Patch in months and only problems. Next one was a sync problem with ActiveSync and a Samsung 8...
Previous Topic: Users with Editor privilege can delete shared calendar
Next Topic: Kerio, CentOS7 and AD LDAP KDC Authentication
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Nov 20 08:19:54 CET 2018

Total time taken to generate the page: 0.83774 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.