Home » Kerio User Forums » Kerio Connect » Gmail says messages are not encrypted
  •  
brandonh75

Messages: 27
Karma: 0
Send a private message to this user
Gmail says that emails sent from our Kerio Connect server are not encrypted.

We have "Use SSL/TLS if supported by remote SMTP server" enabled in the SMTP Delivery settings, and ServerTlsProtocols set to "TLSv1.1,TLSv1.2" in mailserver.cfg. Is there another setting we are missing?

Thanks!

KC 9.2.5 p3
Windows Server 2012 R2

  •  
freakinvibe

Messages: 493
Karma: 72
Send a private message to this user
That should be enough. Switch on the "SMTP Client" logging in the debug log and send a test email to GMail. You should see:

[29/Jun/2018 05:47:15][2788] {smtpc} Sending email to SMTP server gmail-smtp-in.l.google.com, delivering mail from <you<_at_>yourdomain.com>
[29/Jun/2018 05:47:15][2788] {smtpc} Connecting to server gmail-smtp-in.l.google.com (108.177.126.27:25) using local interface 0.0.0.0 ...
[29/Jun/2018 05:47:15][2788] {smtpc} Connected to SMTP server gmail-smtp-in.l.google.com
[29/Jun/2018 05:47:15][2788] {smtpc} Received greeting: 220 mx.google.com ESMTP s33-v6si3201209edb.123 - gsmtp
[29/Jun/2018 05:47:15][2788] {smtpc} Sending EHLO
[29/Jun/2018 05:47:15][2788] {smtpc} Switching connection to TLS
[29/Jun/2018 05:47:15][2788] {smtpc} Sending EHLO
[29/Jun/2018 05:47:15][2788] {smtpc} Sent MAIL command

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
brandonh75

Messages: 27
Karma: 0
Send a private message to this user
Thank you for your reply.

Here's is what I get. No mention of switching to TLS.

[29/Jun/2018 09:49:25][14132] {smtpc} Sending email to SMTP server gmail-smtp-in.l.google.com, delivering mail from <me<_at_>mydomain.com>
[29/Jun/2018 09:49:25][14132] {smtpc} Connecting to server gmail-smtp-in.l.google.com (74.125.124.27:25) using local interface 0.0.0.0 ...
[29/Jun/2018 09:49:25][14132] {smtpc} Connected to SMTP server gmail-smtp-in.l.google.com
[29/Jun/2018 09:49:25][14132] {smtpc} Received greeting: 220 mx.google.com ESMTP o22-v6si6549970ioh.129 - gsmtp
[29/Jun/2018 09:49:25][14132] {smtpc} Sending EHLO
[29/Jun/2018 09:49:25][14132] {smtpc} Sent MAIL command

This has been happening for some time. I remember noticing the red padlock in Gmail in emails from our system a long time ago, I just figured I should finally look into it.
  •  
brandonh75

Messages: 27
Karma: 0
Send a private message to this user
Welp, I sort of figured it out.

It is something with our firewall that is apparently not allowing the TLS connection. Time to track that down.

Thanks again!
  •  
freakinvibe

Messages: 493
Karma: 72
Send a private message to this user
Is your firewall doing SMTP traffic inspection? If so, it might not let you encrypt the traffic as it could not look into encrypted data. You might want to switch that off as we are talking about outgoing mails here.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
Previous Topic: NO Tech Support in TEXAS 9.2.6 patch 2/9.2.7
Next Topic: Kerio Connect 9.2.7 and data enryption - only 16GB storage after encryption
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Dec 19 13:24:09 CET 2018

Total time taken to generate the page: 0.88311 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.