Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » IMAP login from non-default domain?
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
I can't log in to my 6.0.3 server with an IMAP client (either Outlook or Eudora) to a domain that's not the default domain on my server. It appears that the default domain name is being appended to the login name, and that's wrong.

If my default domain is default.com and my secondary is secondary.com, and the user is user<at>secondary.com, then if I log in as "user" the login attempt is made to user<at>default.com (wrong) and if I log in as "user<at>secondary.com" the login attempt is made to "user<at>secondary.com<at>default.com" - also wrong.

Is there any way to use IMAP clients for mailboxes in non-default domains?
  •  
mkanat

Messages: 72

Karma: 0
Send a private message to this user
Yes, it's easily possible; I do it all the time. However, your client seems to be misbehaving. I would contact the support for your client and ask them.

-Max

Maxwell Kanat-Alexander
2nd Level Support Engineer, USA
Kerio Technologies
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
And what client do you use to do that? It certainly COULD be the client(s), but it's a little odd to find exactly the same behavior with two completely different clients, Outlook and Eudora.
  •  
mkanat

Messages: 72

Karma: 0
Send a private message to this user
I've done it with Outlook 2000, XP and 2003. I've done it with Apple Mail, Ximian Evolution, and Eudora 6.

If there were some significant problem with logging into non-Primary domains, my phones would be ringing off the hook about it, and they aren't. Smile

-Max

Maxwell Kanat-Alexander
2nd Level Support Engineer, USA
Kerio Technologies
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
I hope no one at Kerio is answering the phone at all, and is instead spending their time fixing the serious problems with 6.0.3!
  •  
mkanat

Messages: 72

Karma: 0
Send a private message to this user
edmcnierney wrote on Fri, 15 October 2004 13:19

I hope no one at Kerio is answering the phone at all, and is instead spending their time fixing the serious problems with 6.0.3!


Hey Ed. The people who answer the phone and the people who code aren't the same people. In fact, we aren't even in the same office. Smile Though we are in very good communication

If you're having any sort of serious problem with 6.0.3 that is preventing you from using it, please contact support<at>kerio.com and we'll be happy to help you.

-Max

Maxwell Kanat-Alexander
2nd Level Support Engineer, USA
Kerio Technologies
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Just a thought. If you have more than 1 IP on the mailserver this could apply.

Do you have any of the domains bound to a specific IP in KMS admin?
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
Thanks very much for the suggestion! However, that's not the case - there's only one IP on the machine and in use here.
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
Max, I reported my problems to support<at>kerio.com on October 1. Four days later I got a suggestion that my problems might be due to having installed a pre-release 6.0.3 version (something I did not do) and I haven't heard anything since. It's been two weeks since I tried using support, and I have gotten virtually no help at all for multiple, repeatable, serious problems. This thread got started because I'm trying IMAP clients to try to get around blank Web mail messages and Outlook clients that hang.
  •  
mkanat

Messages: 72

Karma: 0
Send a private message to this user
edmcnierney wrote on Fri, 15 October 2004 18:59

Max, I reported my problems to support<at>kerio.com on October 1. Four days later I got a suggestion that my problems might be due to having installed a pre-release 6.0.3 version (something I did not do) and I haven't heard anything since. It's been two weeks since I tried using support, and I have gotten virtually no help at all for multiple, repeatable, serious problems. This thread got started because I'm trying IMAP clients to try to get around blank Web mail messages and Outlook clients that hang.


OK. What's your ticket number? Did you reply and let us know that the suggestion didn't resolve the problem?

-Max

Maxwell Kanat-Alexander
2nd Level Support Engineer, USA
Kerio Technologies
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
Max, let me try to take one specific example and see if we can hunt it down from there. You say you can log in to a non-default domain mailbox in Eudora 6; I can't.

I just set up a new Eudora 6.1.2 install. I have set up one mail account, for an IMAP server we'll call myserver.default.com. In the Eudora "Options" dialog I set the "Login Name" field to "user<at>secondary.com". When I try to connect I'm prompted for the password, with the message "Please enter the current password for:

user<at>secondary.com<at>myserver.default.com

This is wrong, and my attempt to log in does not work. If I change the "Login Name" to just "user", it doesn't work (and I don't expect it to) because there is no "user<at>default.com".

Could you tell me exactly what values you use in Eudora 6 to connect to an IMAP server with a username that's not in the default domain on the Kerio mailserver? Thanks!
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
sonofcolin, you may be on to something. There is only one network interface in the machine, but it has a local address (192.168.0.200). The router does NAT translation to/from the machine's public IP address. This seems to work fine for all other services, but could there be something about IMAP that needs to be different? The IMAP/Secure IMAP services claim to be running, so I didn't expect a problem there.
  •  
edmcnierney

Messages: 11
Karma: 0
Send a private message to this user
Max, I cannot figure out how to either reply to you by email or split off a new thread. I appreciate the help, but didn't want to clog up this thread with a completely separate issue.

I sat around waiting for a few days for a reply by email, and got none. I finally figured out that I needed to check for a reply online instead of waiting for email (nothing told me that), so I checked and replied that the suggestion did not apply. The ticket is KUY-44459 and the specific problem I asked about was the fact that after installing 6.0.3 Outlook 2003 hangs when starting.
  •  
mkanat

Messages: 72

Karma: 0
Send a private message to this user
edmcnierney wrote on Fri, 15 October 2004 19:56

I sat around waiting for a few days for a reply by email, and got none.


Strange -- that can sometimes happen if the support system on support.kerio.com can't send you an email for some reason.

Quote:

I finally figured out that I needed to check for a reply online instead of waiting for email (nothing told me that), so I checked and replied that the suggestion did not apply. The ticket is KUY-44459 and the specific problem I asked about was the fact that after installing 6.0.3 Outlook 2003 hangs when starting.


OK. Reply to the ticket -- that will re-open it. Let them know that the suggestion didn't resolve your problem, and they'll work with you more on it.

-Max

Maxwell Kanat-Alexander
2nd Level Support Engineer, USA
Kerio Technologies
Previous Topic: kerio 6.0.3 versus 5.7.10
Next Topic: Kerio 6.0.3 and tasks
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 22:51:36 CET 2017

Total time taken to generate the page: 0.00578 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.