Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » IP or NIC binding
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Is it possible to get KMS to listen to only a specific IP address or NIC? I know you can bind a domian to an IP, but this isn't the same.

The choices I see are 'All' or '127.0.0.1' I want to choose a specific IP that the mailserver has assigned in the network settings such as 192.168.7.12

[Updated on: Wed, 03 November 2004 23:12]

  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Perhaps a feature request?
  •  
Jonas Quinn

Messages: 31
Karma: 0
Send a private message to this user
Yes, you can. Even for each service a seperate IP-address if you like.

In the Administration Console go to Services. Select the service you like to change and click Edit. Now select the IP-address (or All addresses) and click on Edit. Now you can select an IP-address from the drop down box. You will see all addresses assigned to the host Kerio is running on. Click OK and OK and Apply and you're done. The selected service now only listens on the selected IP.
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Thanks Jonas. I've tried that. I don't see any of my IP's listed except for 127.0.0.1 and 'All' This is with KMS 6.0.3 and OS X. A bug?
  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
i am running on lunux and have all the ips I am using listed in the dialog.

I take it you are editing the all addresses entry

Des Quinn
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
If i try and edit the 'All' address, the only choice in the drop down menu is 127.0.0.1. There is no way to manually add an
ip that i can see.
  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
ok just to be clear this is what I can do in 6.03 on linux

goto services
double click on smtp
click on all addresses (only entry)
click on edit
select drop down box
select one of the ips belonging to your system.
clcik ok



Des Quinn
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
desquinn wrote on Thu, 04 November 2004 13:19


goto services
double click on smtp
click on all addresses (only entry)
click on edit
select drop down box
select one of the ips belonging to your system.
clcik ok


select one of the ips belonging to your system.

I don't have any listed, so this is the problem.

[Updated on: Thu, 04 November 2004 19:48]

  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
just out of interest what os are you running it on?
how many ips do you have on this system?

Des Quinn
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
  •  
Lyle M

Messages: 410

Karma: 7
Send a private message to this user
sonofcolin,

I see the same issue on my configuration (OS X Server 10.3.5, KMS 6.0.3). This looks like an oversight to me. With so many open issues, it's not that surprising. I would report it as a bug to support<at>kerio.com and hope that they get it on their list.

In the meantime, you might want to consider using the All IPs option and use your OS X firewall to block access to the IP address you wish to secure. It gross and ugly, but if it works...

Good luck,
Lylehm
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
I already reported it, but response times from support have become very slow recently (hint, hint!)
  •  
mitch

Messages: 24
Karma: 0
Send a private message to this user
I am running Linux, so I'm not familiar with the Mac installation, but I think all versions use the same mailserver.cfg file. If you are comfortable editing the mailserver.cfg file manually (first stop mailserver, edit file, restart mailserver), then you can probably bypass the bug/problem you are having in the Admin Console.

Find the section that starts with <list name="ServicePorts">. Then find the <listitem> block the corresponds to the service you want to change the IP address for. Enter the IP address you want to use on the line that reads <variable name="IPAddress">0.0.0.0</variable>.

The section in my mailserver.cfg file looks something like this (IP addresses have been changed to protect the innocent):

<list name="ServicePorts">
  <listitem>
    <variable name="Service">SMTP</variable>
    <variable name="IPAddress">192.168.0.10</variable>
    <variable name="Port">25</variable>
  </listitem>
  <listitem>
    <variable name="Service">SMTPS</variable>
    <variable name="IPAddress">192.168.0.10</variable>
    <variable name="Port">465</variable>
  </listitem>
  <listitem>
    <variable name="Service">POP3S</variable>
    <variable name="IPAddress">192.168.0.11</variable>
    <variable name="Port">995</variable>
  </listitem>
  <listitem>
    <variable name="Service">IMAPS</variable>
    <variable name="IPAddress">192.168.0.11</variable>
    <variable name="Port">993</variable>
  </listitem>
  <listitem>
    <variable name="Service">NNTP</variable>
    <variable name="IPAddress">192.168.0.12</variable>
    <variable name="Port">119</variable>
  </listitem>
  <listitem>
    <variable name="Service">NNTPS</variable>
    <variable name="IPAddress">192.168.0.12</variable>
    <variable name="Port">563</variable>
  </listitem>
  <listitem>
    <variable name="Service">HTTP</variable>
    <variable name="IPAddress">192.168.0.13</variable>
    <variable name="Port">80</variable>
  </listitem>
  <listitem>
    <variable name="Service">HTTPS</variable>
    <variable name="IPAddress">192.168.0.13</variable>
    <variable name="Port">443</variable>
  </listitem>
  <listitem>
    <variable name="Service">SIEVE</variable>
    <variable name="IPAddress">0.0.0.0</variable>
    <variable name="Port">2000</variable>
  </listitem>
</list>
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
I just tried your suggestion. However, none of the services will start with this setup. I get an error complaining that a service couldn't bind to the selected IP as the port is in use by another application.
mitch

Messages: 24
Karma: 0
Send a private message to this user
Hmmm. Not sure then. Sounds like you are already running another application that is using the same IP/port combinations or Kerio MailServer is "locking" them all before trying to grab them for the individual services.

Is an IP Address set for your "BindIP"? If it is currently 0.0.0.0, try setting it to one of the IP addresses you are trying to use and see if you get a different error message.

See:
<table name="Misc">
 ...
 <variable name="BindIP">IP Address Here</variable>
 ...
</table>

Previous Topic: German Special Characters (Unicode - Ö Ü Ä)
Next Topic: Mail not being process through the spam filter?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Nov 22 02:32:30 CET 2017

Total time taken to generate the page: 0.00521 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.