Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » sendmail on linux not working on 6.0.6
  •  
kird03

Messages: 4
Karma: 0
Send a private message to this user
Hi,

I've been testing kerio mailserver on linux for some days (version 6.0.4)
I'm using php to send out e-mails through the sendmail program..
this worked fine..
today I upgraded to 6.0.6 and suddenly I can't sent e-mails through php anymore
SMTP server works fine and can be used to send mails...

when de-installingen and putting 6.0.4 back.. it works again..
PHP settigns should be fine then I think..

also i tried 6.0.5 version.. but also this version does not work!!

Who can help me out?!

[Updated on: Fri, 07 January 2005 13:12]

  •  
bmdv

Messages: 110

Karma: 0
Send a private message to this user
hi,

we have the same problem here linux (debian) with 6.0.6

hello kerio please help us!!!

is there a plan for a new version 6.0.7 before 6.1?

Bastian

[Updated on: Thu, 13 January 2005 13:26]

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
techt wrote on Thu, 13 January 2005 11:46

hi,

we have the same problem here linux (debian) with 6.0.6

hello kerio please help us!!!

is there a plan for a new version 6.0.7 before 6.1?

Bastian


I can't help you until I have enough informations.
Does the sendmail utility print any error message to console (stderr)?
What exactly didn't not work?
The sendmail utility is still same since 6.0.3 to 6.0.6. There is no difference.
  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
i have no issues with the kerio sendmail app running on an RH linux distro. this is being used by a few different php based apps and from bash shellscripts

Des Quinn
  •  
bmdv

Messages: 110

Karma: 0
Send a private message to this user
ok here comes the informations you need

no there was no error message, not on stderr or in the kerio debug.log

exactly any php send function call that uses the kerio sendmail wrapper, eg. phpbb, mambo (cms) or a simple script php that send only an email

o there are filesize differences in the sendmail util (i call it wrapper) there must be any difference.

sorry more information i don't have only that is now works with 6.0.4 w/o any problems but there are other problems that was fixed in 6.0.6 n:(

please help

Basti
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
techt wrote on Thu, 13 January 2005 14:52

ok here comes the informations you need

no there was no error message, not on stderr or in the kerio debug.log

exactly any php send function call that uses the kerio sendmail wrapper, eg. phpbb, mambo (cms) or a simple script php that send only an email

o there are filesize differences in the sendmail util (i call it wrapper) there must be any difference.

sorry more information i don't have only that is now works with 6.0.4 w/o any problems but there are other problems that was fixed in 6.0.6 n:(

please help

Basti



There are no differences in filesize in all versions (6.0.3 - 6.0.6) is same file (849 389 bytes).

Moreover, Debian is not supported distribution, there is no official installation package, only RPMs.

I can't help you because we do not support non-official installations.
  •  
kird03

Messages: 4
Karma: 0
Send a private message to this user
PavelDobry wrote on Thu, 13 January 2005 13:36


I can't help you until I have enough informations.
Does the sendmail utility print any error message to console (stderr)?
What exactly didn't not work?
The sendmail utility is still same since 6.0.3 to 6.0.6. There is no difference.


this is what I did:
installed KMS 6.04 on Mandrake 10.0 (.386 rpm, package)

this worked fined after changing in php.ini the sendmail_path to:
sendmail_path = /opt/kerio/mailserver/sendmail -t -i

after testing all mail functions I saw last version was 6.06
I removed rpm package
installed 6.06 and php couldn't send mail anymore (result: FALSE)
installing 6.04 again fixed the problem...

then I tried this:
back-up sendmail executable,
upgraded to 6.06 and replaced sendmail with "old" version
again it doesn't work..

but I undersood, that send-mail hasn't changed at all..
this mains somenting in KMS has changed/disabled the relaying of sendmail..

hope this will help you in finding a possible cause?!

[Updated on: Thu, 13 January 2005 15:52]

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
kird03 wrote on Thu, 13 January 2005 15:52

PavelDobry wrote on Thu, 13 January 2005 13:36


I can't help you until I have enough informations.
Does the sendmail utility print any error message to console (stderr)?
What exactly didn't not work?
The sendmail utility is still same since 6.0.3 to 6.0.6. There is no difference.


this is what I did:
installed KMS 6.04 on Mandrake 10.0 (.386 rpm, package)

this worked fined after changing in php.ini the sendmail_path to:
sendmail_path = /opt/kerio/mailserver/sendmail -t -i

after testing all mail functions I saw last version was 6.06
I removed rpm package
installed 6.06 and php couldn't send mail anymore (result: FALSE)
installing 6.04 again fixed the problem...

then I tried this:
back-up sendmail executable,
upgraded to 6.06 and replaced sendmail with "old" version
again it doesn't work..

but I undersood, that send-mail hasn't changed at all..
this mains somenting in KMS has changed/disabled the relaying of sendmail..

hope this will help you in finding a possible cause?!



Ok, it's definitely not related to the sendmail utility.
Try to enable SMTP logging in the Debug log (in Administration Console). It will help in finding the cause.

BTW: Mandrake also is not one of supported distributions. it is possible that you are using different system libraries that we never tested.
  •  
bmdv

Messages: 110

Karma: 0
Send a private message to this user
that's what we now testet here. same problem occours :(

there must be a change in kms in combination with the sendmail warpper.

->hello pavel,

thats true that debian wasn't suportet by kerio but it's linux and the problem was under debian and mandrake

when you try to send a mail by hand

---cut---
sendmail test<_at_>domain . com
body text
q
.
---cut---

it works, but when php try to send it fails
and in the debug.log is nothing to find SMTP logs are both enabled


there ist only one distribution that is supportet from kerio,
why you write from distributions?

are there other that i dont know? i know only redhat

--cut---
BTW: Mandrake also is not one of supported distributions. it is possible that you are using different system libraries that we never tested.
---cut---

that with the libs was a joke from you, i hope...

Basti
  •  
kird03

Messages: 4
Karma: 0
Send a private message to this user
PavelDobry wrote on Thu, 13 January 2005 15:56

kird03 wrote on Thu, 13 January 2005 15:52

PavelDobry wrote on Thu, 13 January 2005 13:36


I can't help you until I have enough informations.
Does the sendmail utility print any error message to console (stderr)?
What exactly didn't not work?
The sendmail utility is still same since 6.0.3 to 6.0.6. There is no difference.


this is what I did:
installed KMS 6.04 on Mandrake 10.0 (.386 rpm, package)

this worked fined after changing in php.ini the sendmail_path to:
sendmail_path = /opt/kerio/mailserver/sendmail -t -i

after testing all mail functions I saw last version was 6.06
I removed rpm package
installed 6.06 and php couldn't send mail anymore (result: FALSE)
installing 6.04 again fixed the problem...

then I tried this:
back-up sendmail executable,
upgraded to 6.06 and replaced sendmail with "old" version
again it doesn't work..

but I undersood, that send-mail hasn't changed at all..
this mains somenting in KMS has changed/disabled the relaying of sendmail..

hope this will help you in finding a possible cause?!



Ok, it's definitely not related to the sendmail utility.
Try to enable SMTP logging in the Debug log (in Administration Console). It will help in finding the cause.

BTW: Mandrake also is not one of supported distributions. it is possible that you are using different system libraries that we never tested.



first of all: I have no idea how to enable smtp logging in the console...
2nd: php mail function doesn't use smtp I think.. smtp server works fine, I can telnet to port 25 and all responses are fine..
Somehow on linux php can't use an smtp server setting, but needs sendmail?!!

this is where my knowledge stops...
but I didn't change my linux distro inbetween.. therefoe somehow the suport of mandrake (and debian) has stopped when upgrading KMS?!!
  •  
oejel

Messages: 1
Karma: 0
Send a private message to this user
kird03 wrote on Thu, 13 January 2005 16:34

first of all: I have no idea how to enable smtp logging in the console...
2nd: php mail function doesn't use smtp I think.. smtp server works fine, I can telnet to port 25 and all responses are fine..
Somehow on linux php can't use an smtp server setting, but needs sendmail?!!

this is where my knowledge stops...
but I didn't change my linux distro inbetween.. therefoe somehow the suport of mandrake (and debian) has stopped when upgrading KMS?!!


Hello kird03,

1st - You have to enable SMTP logging using the "Administration Console" not using the Linux-Console(tty)

2nd - here you were right. php use the "mail" function directly with the sendmail-wrapper. This initiate a local Mail Delivery and don't use SMTP over port 25.

you are also right, that linux php cannot handle with externalt SMTP-Servers using the "mail"-Function. You have to use sendmail or a similar Wrapper.

and btw.. Mandrake and Debian was never supported by Kerio. That doesn't mean that it didn't works fine :)

I'm using Debian 3.1 Sarge and have the same probs like u

kms 6.0.4 php + sendmail-Wrapper works fine
kms 6.0.5 + 6.0.6 ... broken

Greets J. Kalawinski
  •  
kird03

Messages: 4
Karma: 0
Send a private message to this user
oejel wrote on Thu, 13 January 2005 17:01



Hello kird03,

1st - You have to enable SMTP logging using the "Administration Console" not using the Linux-Console(tty)

2nd - here you were right. php use the "mail" function directly with the sendmail-wrapper. This initiate a local Mail Delivery and don't use SMTP over port 25.

you are also right, that linux php cannot handle with externalt SMTP-Servers using the "mail"-Function. You have to use sendmail or a similar Wrapper.

and btw.. Mandrake and Debian was never supported by Kerio. That doesn't mean that it didn't works fine :)

I'm using Debian 3.1 Sarge and have the same probs like u

kms 6.0.4 php + sendmail-Wrapper works fine
kms 6.0.5 + 6.0.6 ... broken

Greets J. Kalawinski



thank you...!
For sure I'm happy that it wasn't me who screwed up the sendmail function.... ;-)

I hope the "unofficial" support for mandrake and sendmail does come back in later upgrades...
  •  
bmdv

Messages: 110

Karma: 0
Send a private message to this user
hi kird03,

we had now fixed the problem.
is was an error in the rights of the
folders /opt - kerio and mailserver
set it to 755 and it works.
in all other versions before 6.0.5 it makes no sense :-/

but i don't understand why the support was unable to give us a little help :-(

but there is another problem with 6.0.7 when we installed the new version it shutdown itself as soon you connect in any way to the server (admin/imap/smtp/webmail)

regards,
bastian
Previous Topic: send mail only on local domains
Next Topic: Entourage POP errors?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Nov 21 14:36:21 CET 2017

Total time taken to generate the page: 0.00489 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.