Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Another 6.0.9 Bug
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user

Since 6.0.9 was installed when I try to access the webmail I get the following error:

Fatal error: Call to undefined function: savehandlerread() in c:\program files\kerio\mailserver\webmail\default\KmsSessionMgr.inc on line 108

Luckily the webmail was so awful I have no users actually using it or this would be yet another major bug..

Anyone else hasd the same problem.

  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Have you entertained the idea that it could be a problem with your server or the client browser rather than KMS?

Webmail works great with us. Fast and reliable. I have yet to see a better webmail implementation (and we have tried many!)
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user
No I haven't

The webmail worked (HAHA). I mean functioned. I mean STRUGGLED until 6.0.9 (And I mean until immediately before 6.0.9 install)

AND I get this error on all of our (200ish) machines tried on so far so I somehow doubt it is the clients browser!!!

Don't appreciate being patronised

Thankyou for your productive input......
  •  
nickrooster

Messages: 88
Karma: 0
Send a private message to this user
Peter -
Did you turn off chunking and gzipping? Are your clients using only IE? If your answer was yes to either, then that is your problem.
Pavel has stated in the 6.09 impressions thread, I believe, how to turn those options off to make webmail work for IE again.
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user
Have tried the combinations of GZip & Chunking settings Pavel suggested - no joy.

Clients are a mixture of MS Ie & Firefox mainly.

  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
I can only comment on our user experience, which has been great in the later versions of KMS. Webmail was very slow with the early versions of KMS, but now it's very good. We have users connecting from all over the world and none complain about speed or functionality.

You seem to moan more than anyone else on this forum, which is why i questioned your setup. With all of the bugs your finding I'm suprised you have so much time to report them all! Does your boss read these forums?
  •  
nickrooster

Messages: 88
Karma: 0
Send a private message to this user
Peter,
I saw someone else had a similar error (Transport Endpoint was not connected - or similar), I thought that one looked funny as I get loads of those in my samba server logs everyday. Same function name and everything. They must be using the same bits of whatever they do TCP with. But anyway, is the webmail process running on the port you want it to? Is it running at all? My guess is yes, as you are an old hand at this, but it never hurts to ask ;)
-Nick
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user
Nick - Yes & Yes..

Config has not changed since UPG to 6.0.9 .

  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user
SonOfColin,,,

Is it unreasonable to 'moan' when the latest upgrade to KMS breaks it again.... (& not in a small way)

I have about 30bugs listed with Kerio support currently - not one of which were addressed in 6.0.9 - most of them have been outstanding since last year!!!

I am glad you are finding the experience so delightful & bug-free but perhaps you are just in denial..

I think the main reason for my negative attitude is that I have heard the words "wait for 6.1" about three dozen too many times in the last nine months.

Yet somehow I still (mainly) use the forum to help others facing similar bugs.

As for the time spent "finding all these bugs" - what can I say, thanks to those marvellous people at Kerio they seem to find me!!!

I have enough experience with this kind of software to know that it shouldn't be this way. I have been using Kerio products for years & I can tell the difference between previous efforts and this lemon!!
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Well Peterj,

I'm sorry that you find it such a lemon! Have you tried other products?

It is never unreasonable to moan (if justified). What I object to is whinning and 'it's such a crap product' statements (not a quote, just a generalization). Makes you sound like a prat for using KMS if you have such a low opinion of it.

I have experienced a few bugs, reported them to support and they've been fixed. Fairly simple and painless procedure. Response was quick and curteous. I think I have filed about 5-10 reports since 5.7.9 and they have all been handled to my satisfaction. Have you upset anyone at kerio support?

It appears that a lot of issues mentioned on these forums are related to outlook/windows setups. We don't have any, so don't see these problems, therefore can't comment on or share your frustration. No denial I'm afraid.
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user

Well that probably explains it.

You think there are no problems because you are not using the buggy bits.

Most of the issues are caused by or connected to use of the KOC.

That said I would rather have the 5.x version webmail back any day!!!

I continue to use KMS in the hope that it will get better as I am constantly promised by the guys in support.

Plus thanks to 5.x & it's predecessor from the Tiny days I know that it can be better...

Fingers Crossed..
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Peterj,

Yes, I liked 5x webmail too. However, 6 has more features and is almost as fast, so I'm happy.

I hope that kerio finds a way to get all things working on all platforms. I've said this before and I'll say it again: Kerio really does support all platforms equally (and this is a tough thing to do) and I appreciate this refreshing approach!

KMS does a lot of things well and some things not so well. In a perfect world it would all work wonderfully but this isn't always kerios fault. They do respond and do give feedback to their customers. Sometimes what they say you may not like (6.1 delay for example), but this isn't belligerence on their behalf. I?m sure they are trying to make KMS 6.1 as stable and useable as possible because of the feedback they get from their customers. I think they do listen to what people have to say and do want to produce killer apps that work as advertised.

It is good to have a forum with a balanced view. I hate reading complaints all of the time and I appreciate the support that forum contributors have given.

p.s I don?t work for or have any affiliation to Kerio!

Enjoy a hassle free weekend.
  •  
mrshermanoaks

Messages: 35
Karma: 0
Send a private message to this user
Myself and our clients *love* the webmail....
  •  
sophos9

Messages: 107
Karma: 0
Send a private message to this user
Sonofcolin

I totally have to agree with peterj. I'm in the same predicament and as I'm sure you will appreciate, migrating from KMS is a big deal. My experience of Kerio is mixed, I use KWF which is great, lacking some features but does its job well.

On the other hand, I have emailed complaints to support and never even received and answer. The bugs which I'm up against (and many others) are enough to cause a massive pain in the a$$ but when you have created the budgets for the year you are going to look plenty stupid trying to justify the cost of a migration due to the current product which you probably specced not working that well.

In my opinion, KMS whilst looking pretty needs sorting and hopefully 6.1 will do that. In the meantime peterj, keep up the good work!

peterj

Messages: 852
Karma: 1
Send a private message to this user
sophos9

Thanks for the support...

It isn't difficult to see all the new problems 6.0.9 has caused from the last weeks worth of forum postings.

(KMS SVC Crashing frequently, Webmail Compression/Chunking Prob, New webmail (refresh) issues, Old Previewing probs returning.)

& not only that the message hanging in the outbox sorts of problems are not resolved - So much for the fabulous "Re-written transport provider"

Also suddenly the KOC http auto-update doesn't work for 6.0.9 leading to more hassle. Plus the KOC is still as slow & flaky as ever.

Anyway I've started complaining again so I'll shut up now.

http://forums.kerio.com/index.php?t=msg&th=5610&star t=0&S=267d0aed2b35b417e70e892aee22f123

http://forums.kerio.com/index.php?t=msg&th=5614&star t=0&S=267d0aed2b35b417e70e892aee22f123

http://forums.kerio.com/index.php?t=msg&th=5619&star t=0&S=267d0aed2b35b417e70e892aee22f123

http://forums.kerio.com/index.php?t=msg&th=5563&star t=0&S=267d0aed2b35b417e70e892aee22f123
Previous Topic: Mail Services Stop
Next Topic: KMS 6.0.8 Midnight mail queue freezing
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 20:58:23 CET 2017

Total time taken to generate the page: 0.00551 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.