Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Domain Literals
  •  
keneisman

Messages: 15
Karma: 0
Send a private message to this user
Perhaps I don't have KMS configured correctly. If I attempt to send an email using a domain literal (i.e. me<_at_>[66.139.254.194] vs. me<_at_>co.matagorda.tx.us), KMS attempts to resolve (and, of course, fails) [66.139.254.194] instead of sending directly to 66.139.254.194 as it should. Any help would be appreciated.

Thanks
Ken
  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
why use domain literal, use DNS or hosts files

Des Quinn
  •  
keneisman

Messages: 15
Karma: 0
Send a private message to this user
Because right now I'm just testing this server and I don't have any MX records set up to point to it. Anyway, 'why' is not important. Domain literals should work and for some reason they don't.
  •  
peterj

Messages: 852
Karma: 1
Send a private message to this user
Desquinn,

Keneisman is correct, this should work.

Kerio are obviously not interested in industry standards like in RFC821.

  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
I was not defending it ..... Just in similar situations then I would use DNS or host files rather than literals.

To be honest the only use of literals that I have seen of late are with spammers.

but if we talk about RFC compliance then it also does not accept mail for postmaster (RFC2821) either.

A quick test with it shows that it will accept and parse mail for domain literals (domain literal used is the ip address of the server) but just does not deliver them to anywhere so far.


Des Quinn
  •  
keneisman

Messages: 15
Karma: 0
Send a private message to this user
Quote:


A quick test with it shows that it will accept and parse mail for domain literals (domain literal used is the ip address of the server) but just does not deliver them to anywhere so far.




How did you test this? The error I got and what I saw in the logs was a DNS error stating that it could not resolve [66.139.254.194]. Am I missing something? I very well could be since I'm just testing KMS for the first time. I know that I can send mail TO KMS (from antoher MTA) as long as I have the domain literal setup as an alias for my domain but when I try to send mail OUT through KMS it tries to resolve the literal address through DNS instead of just sending in out.

Thanks
Ken
  •  
desquinn

Messages: 145
Karma: 0
Send a private message to this user
my quick test was sending an email to the kerio MTA as a domain literal.

Des Quinn
  •  
keneisman

Messages: 15
Karma: 0
Send a private message to this user
This is the 'mail' log entry when I try to send a domain literal address through KMS:
*************************************************
[26/Apr/2005 16:06:25] SMTP: From: <me<_at_>co.matagorda.tx.us>, To: <me<_at_>[66.139.254.194]>, Size: 1432, Sender-Host: 66.139.254.193, User: me<_at_>co.matagorda.tx.us
[26/Apr/2005 16:06:25] DSN: From: <>, To: <me<_at_>co.matagorda.tx.us>, Size: 1691, Report: failed
**************************************************

And this is the returned mail message:
**************************************************
This is an informative message sent by Kerio MailServer 6.0.9 at mail01.co.matagorda.tx.us.
The server was not able to deliver your mail message to the following addresses:

<me<_at_>[66.139.254.194]> (mail01.co.matagorda.tx.us: Host not found)
****************************************************

To me, this looks like it tried to resolve [66.139.254.194] through DNS - hence the 'Host not found' error.

Is there some other place I can look to get a more detailed idea of what's going on? Is there some session logging I can turn on?

Thanks
Ken
  •  
pmcnett

Messages: 5
Karma: 0
Send a private message to this user
Here is how you can configure your Kerio mailserver to accept domain literals:

1) Open up kadmin, go to Domains, select your domain, click 'edit'. In the aliases tab, add an entry for your public ip address. This entry field won't let you enter the square brackets; don't worry about this yet, just enter the ip address.

2) Close the kadmin screen and apply your changes.

3) Using your command shell, navigate to your Kerio Mailserver application directory. Default for Linux is /opt/kerio/mailserver - I'm not sure about Windows or Mac.

4) Edit the file named mailserver.cfg. Search for your ip address alias entry. Make sure you are editing an entry that looks similar to:

<listitem>
<variable name="Domain">216.139.37.140</variable>
<variable name="Type">2</variable>
<variable name="Alias">paulmcnett.com</variable>

Simply change the "Domain" entry to add the square brackets. For example:

<listitem>
<variable name="Domain">[216.139.37.140]</variable>
<variable name="Type">2</variable>
<variable name="Alias">paulmcnett.com</variable>

5) Save the cfg file.

6) Restart Kerio Mailserver.

I tested this with Kerio Mailserver 6.1.3, and it is working fine. Until Kerio adds this automatically, at least we have this workaround.

Paul McNett
http://paulmcnett.com
Previous Topic: rss-feeds, pop3 and groupview questions
Next Topic: Kerio MailServer 6.1.4 released!
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 04:05:20 CET 2017

Total time taken to generate the page: 0.00517 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.