Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Why Can't I Run Webmail With IIS?

Messages: 3
Karma: 0
Send a private message to this user

I don´t obtain access to webmail! I obtain this php message in the browser:

Fatal error: Call to undefined function kerio() in E:\..\Kerio\MailServer\webmail\default\ on line 43

I don´t know the problem with the file, becauese is encoder with zend encoder.
I´m alredy assign different ports to the kerio mail services too and nothing.

I´m using Windows 2000, IIS 5.0, KMS 6.0.9, PHP 5.0.4 and Zend Optimizer 2.5.10

Somebody can I help me?


[Updated on: Tue, 08 August 2006 22:48] by Moderator


Messages: 6
Karma: 0
Send a private message to this user
Same as mine!
Did you solve it yet and how? Thanks
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
WebMail cannot run on IIS. It must run on Kerio MailServer.

Messages: 511
Karma: 1
Send a private message to this user
I think this deserves sticky status.

Joshua Thomas
Technical Support Manager
2350 Mission College Blvd, Suite 400
Santa Clara, CA 95054
Phone: (408) 496-4500
Fax: (408) 496-6902


Messages: 3
Karma: 0
Send a private message to this user
Yes, the error was solved. I only changed the ports of the KMS and successfully!!

[Updated on: Tue, 19 July 2005 21:34]


Messages: 3
Karma: 0
Send a private message to this user

Yes, the IIS was the problem, I was trying access webmail with IIS, so I din't success.
(e.g. http://localhost/mail/, where mail is an alias to kerio/mailserver/webmail/, this don't worked)

After of the changed HTTP port KMS and access directly it's Ok.
(e.g. http://localhost:8080, worked successfully)

Thanks very much.

PS: I changed the version PHP to 4.4.0 too, so the last version Zend Optimizer was having incompatibility problem with this version of the PHP, so they solved this.(

[Updated on: Tue, 19 July 2005 22:01]


Messages: 25
Karma: 0
Send a private message to this user
You can run Kerio Webmail and IIS if you assign the Sites in IIS to specific IP addresses by using the instructions below:

To run Kerio WebMail from port 80/443 on a server with IIS installed you will need to perform a few tasks:

-Bind IIS sites to an IP
-Disable Socket Pooling for IIS
-Bind Kerio HTTP/Secure HTTP to an IP

Bind IIS Sites to an IP

1- Open IIS and select the web site you want to bind. Right click and select [Properties].

2- Click the drop down in the 'Web Site' tab and select the IP you want to bind the web site to.

3- Click OK and stop/restart the web site.

Disable Socket Pooling
(IIS 5.0, 4.0, Windows 2000 and earlier)
1- Open a command prompt and make sure you are in the X:\Inetpub\Adminscripts folder (where X is the IIS installation drive). To do this, type the following lines at the command prompt:

2- After you open the Adminscripts folder, type the following line at the command prompt:
cscript adsutil.vbs set w3svc/disablesocketpooling true

3- The command replies as follows:
disablesocketpooling : (BOOLEAN) True

4- Stop and start the IIS Admin service.

5- Restart the WWW service.

(IIS 6.0, Windows 2003)

1 Click Start, and then click Run.
2 Type cmd, and then click OK to open a command prompt.
3 Type the following, where is the IP address you want to add:
httpcfg set iplisten -i

When this succeeds, Httpcfg returns the following:

HttpSetServiceConfiguration completed with 0

To view additional status codes, see the Httpcfg help.
After the IP address is added, use the following command to list it:
httpcfg query iplisten

Httpcfg returns the following:


Bind Kerio HTTP/Secure HTTP to an IP

1- Open the Kerio console and select Configuration.

2- Select Services, then HTTP/Secure HTTP.

3- Modify the listening address to its own IP

4- Restart the HTTP/Secure HTTP services.


Messages: 7
Karma: 0
Send a private message to this user
i use another solution :

kerio http service is running on port 10080,
and i've apache with a local proxy forward that send requests to kerio.

internet -[crypted:443]-> apache -[uncrypted:10080]-> kerio

this is my apache conf :

ServerName webmail.***.com
ServerAdmin webmaster<_at_>***.com

ProxyPass /
ProxyPassReverse /

ErrorLog "c:/logs/apache/webmail_ssl_error.log"
TransferLog "c:/logs/apache/webmail_ssl_acces.log"

SSLEngine on

SSLCertificateFile "C:/Appz/Internet/Apache/conf/ssl/webmail.cert"
SSLCertificateKeyFile "C:/Appz/Internet/Apache/conf/ssl/webmail.key"

ErrorDocument 502 "Erreur 502.<br>WebMail en maintenance.<br>Si le problème dure plus de 30 minutes : me contacter."
ErrorDocument 503 "Erreur 503.<br>WebMail en maintenance.<br>Si le problème dure plus de 30 minutes : me contacter."
Previous Topic: 4.4.1 cannot connect to remote host
Next Topic: URI Blacklist and Kerio's Spamassassin
Goto Forum:

Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 00:36:41 CET 2017

Total time taken to generate the page: 0.00637 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.