Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » recounting quotas (Storage quota falls below zero)
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
I have at least three users now who's quotas are reporting incorrectly. I know for a fact that most of the users have used over 1Gb of storage, yet for some reason the quota has droped down to a few Mb.

Is there any way to start a re-count of a users storage and have the quota correct itself?

Thanks

Paul.

[Updated on: Fri, 16 September 2005 15:22]


3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user

[Updated on: Fri, 16 September 2005 15:35]


Scott
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
Yea, I did find that and tried it, but it doesn't work for me. After I deleted the stats.usr file and started kerio again the users quota is just reported as 0%.

I've also tried changing all the index.fld files to index.bad and rebuilt them but this didn't help either.

Am I missing something?

Thanks

paul.

[Updated on: Wed, 27 July 2005 15:55]


3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
I've now got another user who's quota seem's to have reset itself. I noticed the following in the logs...

[25/Aug/2005 11:16:16] user_stats.cpp: Storage quota for user user<_at_>domain.com falls below zero
[25/Aug/2005 11:16:19] Last message repeated 73 times

If this keeps happening my quota control is going to be so far away from reality that the disks will potentially fill.

Anyone got any ideas at all what might be causeing it or how I can make the mailserver recount the users quota?

Thanks

Paul.

3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
See this thread

http://forums.kerio.com/index.php?t=msg&goto=24338#msg_2 4346


Please ignore. I didn't see that I already posted that link a while back.

[Updated on: Fri, 16 September 2005 15:37]


Scott
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
Yup, I think that process just resets the quota to 0% though, I need it to show the actual space used.

Maybe the stats.usr file is being deleted or becomming corrupted somehow - who knows. It would cetainly be useful to be able to make the mailserver recount a users quota though, because once this happens to a user the quota is a bit pointless for the rest of the time that user is on the system.

Paul.

3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
Are you shutting down the server when you delete the stats.usr file? If it's still running, it seems to be re-created with the same stats that were there before the deletion.

Scott
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
I only tried deleting the stats file once, and no I didn't reboot the server. Are you suggesting that deleting the file and then rebooting the server might recount the users quota?

Would be nice if it did, although I can't reboot the server for a while so i'll have to wait till later to try it.

3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
You don't need to reboot the server. Just shut down the Kerio service, then delete the file, then restart the service. That's what fixed my user stats.

Scott
  •  
Soup

Messages: 74
Karma: 0
Send a private message to this user
I think the difference is that you wanted yours reset to 0, as you correctly say, deleting the file and restarting kerio does exactly that. My problem is that my users to have a lot of email but the quota does not recognise it.

Thanks for trying though :)

Paul.


sedell wrote on Fri, 16 September 2005 15:21

You don't need to reboot the server. Just shut down the Kerio service, then delete the file, then restart the service. That's what fixed my user stats.


3 x Apple Xserve G5 DP2.3
1 x Apple Xserve RAID
40ish users
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
I had to recount quotas once for a user (I copied mail folders in her folder structure outside of KMS through Windows Explorer). I had to stop KMS, then delete the stats file and then start KMS again. That fixed the quota. It does not work with an online KMS.

Other thing:
I also do get the "quota drops below zero" for some accounts. Haven't been able to fix it.
  •  
jross

Messages: 2
Karma: 0
Send a private message to this user
I get that error message as well, about the quota dropping below zero. It seems to happen with my high traffic shared inboxes the most... havent been able to determine exact conditions yet... more to come.
Previous Topic: Kerio WebMail Incompatible with Opera v8.5
Next Topic: wish: smtp forwarding with "smtp auth"
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 09:38:50 CET 2017

Total time taken to generate the page: 0.00579 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.