Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Kerio is losing my mail!
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
This is incredible! I just started mail, looked for new mail, retrieved about 13 or 14, read the first one, a notification, that someone answered a post of mine, so I clicked the link, read the post and switched back to Mail. But hey, what the f*ck is going on? Instead of 13 unread Mails there is now only one! And the latest Mail in my Inbox is from June, 4th! Where did my mails go? Kerio obviously lost four month of mail!

Shutting down Mail and switching to the Webmail-Frontend, to make sure, this is not only a display issue it is almost the same. The latest mail is from June, 4th, the missing four month are lost.

I read my mail thru Apple Mail. The account is configured as IMAP. When I'm at work, I also use the Webmail-Frontend, but as I'm on holiday currently, I only use Apples Mail-Application.

So, what can I do to get my mail back, before getting rid of a mailserver losing mail?

Matt
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
So nobody in a mood to reply to this huge bug? This isn't incredible, this is ridiculous!

Matt
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
This isn't the place to go to get immediate help on issues like that. Call support.

Scott
  •  
bperkins

Messages: 355
Karma: 0
Send a private message to this user
Matt,

Have you checked the folder on the server itself to see if the mail is in there? It might just be an indexing problem and you will need to reindex the folder.

Just a thought....

BP
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
Is there any chance to do this using the Administration Console?

If not: How can I re-index a folder thru ssh?

Matt
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
msslovi0 wrote on Mon, 03 October 2005 15:27

Is there any chance to do this using the Administration Console?

If not: How can I re-index a folder thru ssh?

Matt


If I'm not mistaken you have just announced to the world that you have discovered a serious bug in KMS, yet you do not know where your mail store is or how the admin console works?

Have you contacted support?

I have some advice - RTFM!
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
sonofcolin wrote on Mon, 03 October 2005 21:34

If I'm not mistaken you have just announced to the world that you have discovered a serious bug in KMS, yet you do not know where your mail store is or how the admin console works?


You are mistaken, but maybe it is because of my English, as I'm not a native speaker.

Quote:

Have you contacted support?


This forum is accesible thru 'Support'. If it is for smalltalk only, it should be labeled correctly.

Quote:

I have some advice - RTFM!


However, a manual for the version I'm running (6.0.10) is not longer available for download. As the subscription period expired and the company owning the server is not willing to pay for another year I can't upgrade to 6.1.x - but if it works the same way: I'm not really keen on losing flags on ~20000 mails.

Matt
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Matt,

If you have lost messages, the following could have happened:
1. Apple mail thought they were junk so moved them.
2. You deleted them without knowing.
3. You have anti virus software running on your server and you forgot to tell it not to scan the /kerio/store folder
4. You have a corrupt user index.fld
5. You have permission issues with your store directory.

The file you are looking for is 'index.fld' and is located in/kerio/store/domain/user. If you delete it, a new one will be created. You should probably stop KMS before you do this.

You will find the 'Administrator's guide' aslo known as the 'manual' is in the same location as your admin console. The page you are looking for is 216.
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
sonofcolin wrote on Mon, 03 October 2005 22:31


1. Apple mail thought they were junk so moved them.


Doublechecked this already and no, Mail.app didn't sort the mail into the junk folder.

Quote:

2. You deleted them without knowing.


If so, they should still be in the trash. But they are not. And I think it is quite hard to delete four month of mail without recognizing what you are doing.

Quote:

3. You have anti virus software running on your server and you forgot to tell it not to scan the /kerio/store folder


As the configuration hasn't changed between yesterday night and this morning, then there must be something real weird going on. So, why should the virus scanner handle all mails correctly for the last year and stop doing so this morning without any changes?

Quote:

4. You have a corrupt user index.fld


That might be. I'll have to check this tomorrow morning. But if I correct this with the solution offered by the manual, I will, as already said, lose flags on about 20000 mails! And I don't know, what is less time wasting. Re-flagging 20000 mails or extracting the missing four month out of the backup.

Quote:

5. You have permission issues with your store directory.


Same as point 3. Why should this work fine for almost a year and stop working just this morning? Also, new mails are arriving just fine, but there ist a four month gap.

Quote:

You will find the 'Administrator's guide' aslo known as the 'manual' is in the same location as your admin console. The page you are looking for is 216.


The only file in the Directory /Applications/Kerio MailServer/ is Administration Console.app. And the help link from the menu is not working...

I'll check both, the #msgs-Directory and index.fld tomorrow morning and let you know.

Matt
  •  
msslovi0

Messages: 12

Karma: 0
Send a private message to this user
Browsing the directory, it looks as the mails are still there. So I might get a little bit to upset in my first few posts, but I hope, everybody can understand this. Anyway, sorry for that.

If I got the manual right, the only solution to fix this is to re-build the index, what, on the other hand, means that I will lose all indexes (read/unread/deleted) on those mails. I will have to discuss this with myself, what will be less time-consuming.

My for now even more important point is how I can avoid this in the future. I'm not keen in running into the same problems in two month. Also, some people using the same Mailserver, sometimes complain, that they haven't received a certain mail, also the sender swears by god, that he has sent it. This, after all, themes to be the same issue, also it is not as obvious, because we are 'only' taking about one email then and not about two thousend...

Matt
  •  
freakinvibe

Messages: 1553
Karma: 62
Send a private message to this user
Matt

If you do regular backups you can restore your messages and .fld files. If you don't, you are at risk of losing your mail anyway through a HD crash or user error.

The problem that people are missing a single mail is unrelated. There are several possibilities how this can happen:

- The mail was considered Spam

- The sending Mail Server had a problem

- It was wrongly addressed

- A rule moved the message out of your inbox

- The sender's mail server is blacklisted

Some of these things might issue an error message to the sender, other's not.

You can only find the answer in the mail server's log files.

Regards, Pascal

P.S.: sonofcolin was right to check if you have excluded the store folder in your AV app on the server. Can produce unpredictable results even if it hasn't done so "for years".

Regards, Pascal

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
Kerio_jthomas

Messages: 511
Karma: 1
Send a private message to this user
Quote:


This forum is accesible thru 'Support'. If it is for smalltalk only, it should be labeled correctly.


Apparently you missed the topic labeled 'How To Contact Kerio Support'?

Did you read the Support page on our website? http://www.kerio.com/support.html

Scott is correct; if you want support, submit a ticket via http://support.kerio.com, or call us.

Cheers,
Joshua


Joshua Thomas
Technical Support Manager
2350 Mission College Blvd, Suite 400
Santa Clara, CA 95054
Phone: (408) 496-4500
Fax: (408) 496-6902
http://www.kerio.com/support.html

Previous Topic: Sync MacOS X adressbook to kerio how?
Next Topic: Spamassassin version w 6.1 upgrade on RH9
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Nov 22 21:32:48 CET 2017

Total time taken to generate the page: 0.00469 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.