Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Tip - Rewriting/Proxying Kerio WebMail URL on IIS with ISAPI Rewrite
  •  
BrianLy

Messages: 3
Karma: 0
Send a private message to this user
Hi

I'm running Kerio with IIS6 on a single server for my company, and thought the following might be useful for others. It can probably be improved somewhat and may not be valid in large scale production environments. Use at your own risk, mileage varies etc.

Problem:

At some client sites, my webmail has been inaccessible due to blocking of urls with port numbers. I can't run Kerio on port 80 since I need to run IIS there.

Kerio WebMail (insecure, non-SSL version) was running at http://mycompany.com:8383.

Solution:

1) Create a new Website (eg. http://mail.mycompany.com in IIS to give you some isolation from other applications. Read up on IIS to understand this process and how to best configure for your needs.

2) Install ISAPI Rewrite from http://www.isapirewrite.com. I guess you could use another ISAPI filter instead if you desire.

3) Install an SSL certificate in your IIS site (optional).

4) Test ISAPI Rewrite installation.

5) Add this rule to your httpd.ini file if your Kerio webmail is on port 8383. (Points to your non-SSL webmail, since IIS can handle this)

RewriteCond Host: (?:mail\.)?mycompany\.com
RewriteProxy (.*) http\://mycompany.com\:8383$1 [I,U]

You can now access your webmail at http://mail.myorganisation.net

-Brian
  •  
qbjack

Messages: 3
Karma: 0
Send a private message to this user
Hello BrianLy.

I followed your Instructions on a W2K3 Server with IIS 6 but I only get a "Directory listing not allowed" message. Can you give me some hints please.

Thanks.
  •  
TorW

Messages: 769
Karma: 9
Send a private message to this user
You likely need to set index.php as default document in the new website. By default only default.asp and index.htm is set up.
  •  
qbjack

Messages: 3
Karma: 0
Send a private message to this user
OK, thanks. I've got it. There was something wrong with the rewriter installation.

Now another problem:

I can not sync with my Symbian phone over the proxied KMS (webmail). The client tells me the password is wrong. Same credentials but connected directly to the KMS, works flawlessly.

Here is some log output from IIS. I get a 401 error but the password and the username is definetely correct.

2009-03-16 19:43:50 W3SVC1719304455 XX.XX.XX.XX OPTIONS /Microsoft-Server-ActiveSync User=thomas&DeviceId=IMEIxxxxxxxxxxxxxxx&DeviceType=IMEIxxxxxxxxxxxxxxx 80 - XX.XX.XX.XX NokiaN82/2.07(0)MailforExchange 401 5 0


Any ideas?

Thanks.

[Updated on: Mon, 16 March 2009 20:58]

Previous Topic: Send secure mail from Mail OS X 10.5 Leopard
Next Topic: Activesync and Windows Mobile 6
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 06:13:02 CET 2017

Total time taken to generate the page: 0.00389 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.