Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » high CPU usage
  •  
worm

Messages: 7
Karma: 0
Send a private message to this user
I have installed KWF on our server which has a 10 Mbps external connection and when someone downloads something at full speed the CPU usage rise at 100%. The winroute.exe process is using all the server's resources... the rest of the clients can't even open a webpage.

the server is an AMD Athlon 64, 512 MB RAM. I know is not such a good system configuration but since one or two months ago the CPU load was ok...

where should i look to repair this problem? What is the minimum configuration for KWF?


PS: KWF is running on Windows Server 2003.
  •  
Kerio_ktrumbull

Messages: 597
Karma: 2
Send a private message to this user
What version of KWF? Note the release notes for patch 2:

Version 6.1.4 Patch 2 - January 19, 2006
- fixed possible hang and 100% CPU consumption while browsing the web

Kevin Trumbull
Kerio Technical Support Team Leader
http://support.kerio.com
  •  
worm

Messages: 7
Karma: 0
Send a private message to this user
i have 6.1.4 patch 2 build 1086

this problem starts when the traffic exceds 1 MBps.
  •  
feite

Messages: 523
Karma: 0
Send a private message to this user
Is it when someone downloads a large file?
  •  
worm

Messages: 7
Karma: 0
Send a private message to this user
yes.

i dont know what else to do. my traffic policy has ~150 rules because I make NAT for for every LAN client + 20 rules for port forwarding. could be this the cause of this high CPU load?
  •  
feite

Messages: 523
Karma: 0
Send a private message to this user
I had the same problems when downloading large files. At a some point during the download (ie reported 99% complete the cpu usage went up to 100%. It stayed there for ever. I had to reboot the firewall machine to get it to work again. User could no longer browse the internet. Connections were lost. The problem is with the anti-virus scanner (mcAfee) of Kerio. It uses one thread to scan files, on at a time. If this takes to long the thread never end. I solved this by assigning a max size to the files to be scanned (anti-virus tab anti-virus engine, set it to 100000 KByte). You can experiment with different sizes.
The bug is known at Kerio. When the make the virus scanning multi threaded it could be fixed. Don't know when...
  •  
worm

Messages: 7
Karma: 0
Send a private message to this user
does mcafee antivirus scans the files even if those files are downloaded with P2P software?
  •  
feite

Messages: 523
Karma: 0
Send a private message to this user
Don't know. You can only set options for HTTP, FTP and email.
  •  
Jeraf

Messages: 27
Karma: 0
Send a private message to this user
It's KWF engine bug.
KFW cannot normally work in high speed networks. At GBit Ethernet it useless.
It's very old bug and i believe kerio just don't care about it.
You can search this forum, many users have same problem.
  •  
mcwf

Messages: 17
Karma: 0
Send a private message to this user
Very Strange… Rolling Eyes


Configuration:

KWF 6.1.4.1086
P4 2.0a Ghz/ RAM 1.5 Gb / SYS: Server 2003 SP1 ENT
2 network cards 100Mbps Local-Uplink

I’m never having problem with a high CPU load… Time from time I’m (and another people in my network) downloading large files ~600-800mb (1-3 cc) maximum speed about ~50Mbps due to hardware limit… and no problem… never.

But I’m using external antivirus SAVC. Smile


P.S. Sorry for my english Cool
  •  
The1st

Messages: 69
Karma: 0
Send a private message to this user
Having analyzed many user's claims concerning "High CPU usage"/"low transfer speed"... I see that most of theirs PCs have Realtek network cards installed. It's really so - realtek network adapter load CPU with KWF (and other network activity). The best solution is using of Intel NIC.

[Updated on: Mon, 13 March 2006 10:24]


/Vladislav
  •  
Kerio_jthomas

Messages: 511
Karma: 1
Send a private message to this user
Turn off all antivirus. Does CPU problem go away?

If so, problem is antivirus.

Joshua Thomas
Technical Support Manager
2350 Mission College Blvd, Suite 400
Santa Clara, CA 95054
Phone: (408) 496-4500
Fax: (408) 496-6902
http://www.kerio.com/support.html

  •  
worm

Messages: 7
Karma: 0
Send a private message to this user
Quote:

Turn off all antivirus. Does CPU problem go away?



no is not
  •  
Kerio_jthomas

Messages: 511
Karma: 1
Send a private message to this user
OK. Go to http://support.kerio.com and submit a ticket.

Joshua Thomas
Technical Support Manager
2350 Mission College Blvd, Suite 400
Santa Clara, CA 95054
Phone: (408) 496-4500
Fax: (408) 496-6902
http://www.kerio.com/support.html

worm

Messages: 7
Karma: 0
Send a private message to this user
i cant send a ticket, because i'm only the administrator of that network. before submitting a ticket i need to ask my superior.

as someone said few posts up, i'm also using realtek NICs... so this could be the problem. i'm gonna change those nics and post a reply with the results.

[Updated on: Mon, 13 March 2006 20:41]

Previous Topic: Multihomed public interface?
Next Topic: Kerio WinRoute v.6.10 with Lotus Notes Release 5 ??
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 15:22:02 CET 2017

Total time taken to generate the page: 0.00601 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.