Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » How Do I Publish a Web Site?
  •  
Linguinut

Messages: 9
Karma: 0
Send a private message to this user
I've searched the forums and techknowledge (helps files are no help), and I cannot figure out how to publish my corporate web site through the WinRoute firewall. Would someone please provide some steps for this? My situation is rather simple. The site is on an internal web server (192.168.1.2:5080) and I would like any user hitting our hostname (www. mycompany.com), which is directed to the external nic on the firewall, to pull up pages on the internal web server.

Thanks for your help!
Ling
  •  
feite

Messages: 523
Karma: 0
Send a private message to this user
Create a traffic rule like this:

name: webservice
source: internet
dest: firewall
service: HTTP
action: allow
translation: MAP 192.168.1.2 port 5080
  •  
Linguinut

Messages: 9
Karma: 0
Send a private message to this user
I did try those settings (and a host of others)...the settings you suggest are the current applied settings. It is still not working. I can hit the site internally (using the IP address and port); however, externally it is not responding. I also turned off the protocol inspector. Any other ideas?
  •  
Linguinut

Messages: 9
Karma: 0
Send a private message to this user
Here is the log entry of the last setting change that I made:

1: name=(Web Site Publication) src=(iface:"External NIC") dst=(Firewall) service=("HTTP") snat=(any) dnat=(192.168.2.6:5080) action=(permit), time_range=(always) inspector=(none)

Still no go...

Ling
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Can you access the Internet from the webserver? Does the webserver have default route to KWF?

Check error and warning log in KWF. Try to enable connection log for the traffic rule you've created.
  •  
Linguinut

Messages: 9
Karma: 0
Send a private message to this user
Here is what I did to solve the problem (which I did just a few minutes ago):

7: name=(Web Site Publication) src=(iface:"External NIC") dst=(Firewall) service=("HTTP") snat=(iface:"Internal NIC") dnat=(192.168.2.6:5080) action=(permit), time_range=(always) inspector=(default)

Notice, that I placed the policy back where it was originally, or at least, close to the location. Also, the source NAT was changed. I had it translate to the internal NIC address. As soon as I did that the site fires right up. No problems, now.

Thanks for your input!
Ling
Previous Topic: how can i add many many url one time?
Next Topic: ADSL's interface support
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 22:42:40 CET 2017

Total time taken to generate the page: 0.00465 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.