Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » How to make direct connection (no proxy)
  •  
bosnic

Messages: 3
Karma: 0
Send a private message to this user
First, sorry my bad english.

I have to connect to a service in a Brazilian Bank. It connects by an Java Applet and use strong encription. The strange thing is that service use port 80 but not http protocol. It is realy strange but it works that way. In service documentation they say that we have to connect directly to their server, without passing through proxy. The question is, what kind of rule do I have to create in my Winroute Firewall (6.0) to say that to connect to that specified server on port 80, 'dont´t use proxy, connect directly'.
Any suggestions?
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
Just create a sraightforward traffic rule for port 80. It might be named as service HTTP, but it KWF actually does not look at the protocols, it just looks at portnumbers. So just make sure you can connect to the bank over port 80 (which you probably already can if you can surf the web).
  •  
bosnic

Messages: 3
Karma: 0
Send a private message to this user
Thank you for your help, but it didn´t work or I don´t know how to make it work. I will be more specific. The bank server has IP adress 200.201.174.207. I am attaching print screen of my configuration.
1st rule is to permit all traffic between my local networks.
2nd rule is for bank service that connect on port 80. There is no
NAT mapping in that rule because i am doing some tests on firewall machine right now.
3 and 4th rules are for my internet access.
When I try to access the bank server, I get an error message in
security log:
(my server IP is 200.241.111.66)

[10/May/2006 08:18:31] HTTP: Non-ASCII bytes detected in HTTP request: client: 200.241.111.66, server: 200.201.174.207

The bank´s help desk says it is because my connection is managed by
a proxy server and their service has to connect directly, cannot pass through proxy. When I used Linux it was easy to configure because
firewall and proxy are two distinct services, but I am new at Kerio
and I really dont know where firewall ends and proxy starts. It seems to me that they are a unique service, so when I try to access a remote machine on port 80, they 'think': 'o, this guy wants to access a remote service on port 80, it has to be some kind of web server so I am going to manage him by proxy'. And I only want to connect directly, using no proxy.
Is it possible to do with KWF???

  • Attachment: fire.jpg
    (Size: 71.75KB, Downloaded 704 times)
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Ok, you need to disable HTTP protol inspector for traffic rule "Caixa". Right click on the traffic rule and choose "Modify columns " from drop-down menu. Enable Protocol inspector column and then click on it and set protocol inspector from Default to None.
  •  
bosnic

Messages: 3
Karma: 0
Send a private message to this user
Thanks

[Updated on: Wed, 10 May 2006 16:08]

Previous Topic: problim in local ip
Next Topic: 6.2.1 Statistics Time Wrong?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 19:35:10 CET 2017

Total time taken to generate the page: 0.00397 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.