Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Big problem with 6.2.0
  •  
rencorp

Messages: 33
Karma: 0
Send a private message to this user
Haven't seen anybody else complain of this, so I thought I would throw this open to the forum ...

Upgraded to 6.2.0 last night. Everything seemed fine. All the new features looked good.

However, this morning, I have had complaints about the lack of email. Some is getting through, but a noticeable amount is not. De;lving deeper into the logs, it looks like every email that is addresses to an email address at my domain that is really an alias to two or more user mailboxes is being bounced back with a DSN to the sender. An email to those mailboxes listing them seperately in the To; address works fine, so it isn't multiple email addresses that is the problem, but rather aliases that are not expanding correctly.

An example from my Mail log reads as follows :-

[21/Jul/2006 10:03:41] Recv: Queue-ID: 44c0986d-00000006, Service: POP3, From: <root<_at_>walker-freight.com>, To: <gary.mason<_at_>rencorp.co.uk>, Size: 1139, server pop.1and1.co.uk, user m37309809-8, mailbox {Envelope-To}
[21/Jul/2006 10:03:41] Recv: Queue-ID: 44c0986d-00000007, Service: POP3, From: <root<_at_>walker-freight.com>, To: <jo.young<_at_>rencorp.co.uk>, Size: 1137, server pop.1and1.co.uk, user m37309809-8, mailbox {Envelope-To}
[21/Jul/2006 10:03:41] Recv: Queue-ID: 44c0986d-00000008, Service: POP3, From: <root<_at_>walker-freight.com>, To: <[backup.status<_at_>rencorp.co.uk]>, Size: 1593, server pop.1and1.co.uk, user m37309809-8, mailbox {Envelope-To}
[21/Jul/2006 10:03:42] POP3 download: 4 messages (40605 bytes) downloaded from server pop.1and1.co.uk, with username m37309809-8
[21/Jul/2006 10:03:42] Sent: Queue-ID: 44c0986d-00000006, Recipient: <gary.mason<_at_>rencorp.co.uk>, Result: delivered, Status: 2.0.0
[21/Jul/2006 10:03:42] Sent: Queue-ID: 44c0986d-00000007, Recipient: <jo.young<_at_>rencorp.co.uk>, Result: delivered, Status: 2.0.0
[21/Jul/2006 10:03:44] Recv: Queue-ID: 44c09870-00000009, Service: DSN, From: <>, To: <root<_at_>walker-freight.com>, Size: 2724, Report: failed

The above log shows what happened when i sent two emails from a customer server. One was addressed to both gary.mason and jo.young in the To: line, the other was addressed to backup.status. The email addressed to both addresses has been delivered correctly. The email to backup.status has been bounced. Both the user accounts above (gary.mason and jo.young) have backup.status as a valid email address set up in each user account.

Anyone else getting this ? I have done all the usual things like reboot etc, but I'm still getting this problem.

Gary
www.rencorp.co.uk

Kerio Certified Business Partner - Messaging
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
To understand correctly: it's not about actual aliasses (as setup in Domain Settings --> Aliases), but about 'real' email addresses (as setup in Domain Settings --> Users --> Mail Addresses tab). It is probably not wise to give more people the same email address, as it is then unclear how KMS handles these addresses.

Why don't you just create a group (Domain Settings --> Groups), give that group the email address backup.status<_at_>yourdomain.com and make Gary and Jo members of that group? That is the proper way to have email delivered to multiple recipients...
  •  
rencorp

Messages: 33
Karma: 0
Send a private message to this user
Yep, you understand correctly. I checked and can confirm that I do have a group already set up as you suggest, with a single email address of backup.status<_at_>rencorp.co.uk and it does indeed only have the two user accounts included.

Does that mean that having the alias email address set up on both the user account email address tab and also in the group will cause problems ? It didn't up to version 6.1.3.

I'll try removing the backup.status alias from the two user account email address tabs and see if that helps.

Gary
www.rencorp.co.uk

Kerio Certified Business Partner - Messaging
  •  
rencorp

Messages: 33
Karma: 0
Send a private message to this user
I have removed the backup.status email from both of the user accounts email address tab and tried a few more tests.

If I send from a PC connected locally to the Kerio server, then sending to backup.status<_at_>rencorp.co.uk works fine. However, emails downloaded using POP3 from the ISP are still being bounced back with a DSN. On the POP3 download screen in the admin console, I have checked to make sure that the download rule (I am using delivery using sorting rules - X-Envelope-To) is there to send the backup.status emails to the backup.status group.

Am I missing something else here ?

Gary
www.rencorp.co.uk

Kerio Certified Business Partner - Messaging
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
rencorp wrote on Fri, 21 July 2006 12:00

Does that mean that having the alias email address set up on both the user account email address tab and also in the group will cause problems ? It didn't up to version 6.1.3.


I doesn't necessarily have to cause problem, but you're sort of introducing ambiguity in the configuration since then there are several 'objects' with the same email address. What should KMS do? Deliver to the first? To all? To one after the other? This is not really defined. Concluding: it could be wise not to leave anything open to interpretation.

Still, why delivery now fails, I don't know. You'd better call support or open a ticket, since that's the only way you're sure you'll get help from Kerio. This forum can be very helpful, but is not official Kerio support.
Previous Topic: We cannot receive email to users in the BCC field.
Next Topic: Annoying interface bug when using web calendar with Firefox
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Nov 22 14:03:56 CET 2017

Total time taken to generate the page: 0.00383 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.