Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KMS, WebSTAR, PHP and Sendmail - Urgent
  •  
keywerks

Messages: 73
Karma: -2
Send a private message to this user
Hi <_at_>all,

we're running a box (Mac OS X 10.4.7) with KMS (6.2.2), Kerio WebSTAR (5.4.2) and PHP (PHPStar 3, surprise, surprise). Now Sendmail will not work at all. We've changed the sendmail_path in php.ini to "/usr/local/kerio/mailserver/sendmail", fixed the access rights (chmod 0755) and have done everything else suggested in the discussion board. But we're unable the get PHP send mails. Sending test mails with terminal won't work, too. The debug never logs a corresponding smtp event.

If I try to send a mail from another Mac to this box, the debug log will print out a corresponding line.

Please help. It's really urgent.

*************************************
PHPStar - the missing gear in your web engine
Visit http://phpstar.keywerks.de
*************************************
  •  
Kerio_ktrumbull

Messages: 597
Karma: 2
Send a private message to this user
Please submit a support ticket: http://support.kerio.com

Kevin Trumbull
Kerio Technical Support Team Leader
http://support.kerio.com
  •  
keywerks

Messages: 73
Karma: -2
Send a private message to this user
Done.

*************************************
PHPStar - the missing gear in your web engine
Visit http://phpstar.keywerks.de
*************************************
  •  
keywerks

Messages: 73
Karma: -2
Send a private message to this user
I?ve found a solution by myself. My SMTP services were bound to only one specific ip address, because of compatibilty reasons (KMS and WebSTAR). The server never responds to any request coming on 127.0.0.1
After adding this ip to the address pool, everything is up and running.

*************************************
PHPStar - the missing gear in your web engine
Visit http://phpstar.keywerks.de
*************************************
  •  
keywerks

Messages: 73
Karma: -2
Send a private message to this user
After updating to KMS 6.3.0 sending mails out of PHP doesn?t work anymore. None of the server settings changed.

Can anybody help me to solve this?

*************************************
PHPStar - the missing gear in your web engine
Visit http://phpstar.keywerks.de
*************************************
  •  
keywerks

Messages: 73
Karma: -2
Send a private message to this user
SOLVED!

Just change Kerio sendmail rights to 755.

*************************************
PHPStar - the missing gear in your web engine
Visit http://phpstar.keywerks.de
*************************************
  •  
komakino

Messages: 16
Karma: 0
Send a private message to this user
I just ran into this problem with a php form under Mac OS X. The form uses the mail() command but when the form was submitted I would see a '/usr/local/kerio/mailserver/sendmail: Permission denied' error in the Apache logs.

This was after following the instructions in the Kerio article on how to get php mail working under Mac OS X. The solution was to change the permissions both on /usr/local/kerio/mailserver directory and /usr/local/kerio/mailserver/sendmail to 755.

Chris Williams
Consulting Engineer
DaVinci Digital
Portland, OR
Previous Topic: How to reset logs? thanks
Next Topic: fax server
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Nov 22 12:20:38 CET 2017

Total time taken to generate the page: 0.00389 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.