Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Problem with iCal/AddressBook in Mac OS X
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
Hi!

I have installed a demo installation of KMS to Power Mac G5 and for some reason can?t get the Ical and addressbook support to work.

I can connect to KMS with email client and webmail. I have both private and public calendars with some test information and both public and private addressbooks with some test contacts.

When I try to connect to the KMS with iCal with http://server_name/ical, http://server_name/ical/user<_at_>domain or http://server_name/ical/domain/user_name I get an iCal error: "Unexpected secure name resolution error (code -9812). The server name KMS_IP_NUMBER may be incorrect.". I have tried the DNS name with same results.

I have no problems connecting via webmail to the same ip number as I stated before.

Same with the address book: if I configure addressbooks LDAP settings as in the KMS "Support of products for Apple Mac OS X" manual and try to browse "Directory" I don?t get any results.

And yes, I have enabled everything in KMS Service?s menu and there is no firewall blocking the traffic (this is in LAN).

Any idea how to get iCal and Addressbook working? Purchasing the KMS depends on these two services:)
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
up.

Any idea/solution for this problem. I really would like to start using KMS as our mailserver solution but can?t get this iCal/Addressbook issue resolved.

Is there any log file on KMS that I could look into to see if the server even recieves calls for iCal?

- Janne
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
cuie wrote on Wed, 01 November 2006 08:41

up.

Any idea/solution for this problem. I really would like to start using KMS as our mailserver solution but can?t get this iCal/Addressbook issue resolved.

Is there any log file on KMS that I could look into to see if the server even recieves calls for iCal?

- Janne


Sure. There is a debug log in KMS which would help us. Just enable HTTP server and WebDAV debug logging (right click in the debug log).
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
Kerio_pdobry wrote on Wed, 01 November 2006 09:41

cuie wrote on Wed, 01 November 2006 08:41

up.

Any idea/solution for this problem. I really would like to start using KMS as our mailserver solution but can?t get this iCal/Addressbook issue resolved.

Is there any log file on KMS that I could look into to see if the server even recieves calls for iCal?

- Janne


Sure. There is a debug log in KMS which would help us. Just enable HTTP server and WebDAV debug logging (right click in the debug log).


I don?t get any errors to the debug-log in KMS. What do you mean by WebDAV debud logging, the Mac OS X Servers WebDAV logging or something else?

I have tried this hint also: http://www.macosxhints.com/article.php?story=200508160042578 76
But no avail.
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
Kerio_pdobry wrote on Wed, 01 November 2006 09:41

cuie wrote on Wed, 01 November 2006 08:41

up.

Any idea/solution for this problem. I really would like to start using KMS as our mailserver solution but can?t get this iCal/Addressbook issue resolved.

Is there any log file on KMS that I could look into to see if the server even recieves calls for iCal?

- Janne


Sure. There is a debug log in KMS which would help us. Just enable HTTP server and WebDAV debug logging (right click in the debug log).


Actually now I found from Security log:
[01/Nov/2006 10:01:30] HTTP request from MY_IP_NUMBER (GET /) redirected to HTTPS because of security policy.
[01/Nov/2006 11:08:09] HTTP request from MY_IP_NUMBER (GET /ical) redirected to HTTPS because of security policy.

Should I change the security policy to some non-secure option or so?
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
cuie wrote on Wed, 01 November 2006 11:39

Kerio_pdobry wrote on Wed, 01 November 2006 09:41

cuie wrote on Wed, 01 November 2006 08:41

up.

Any idea/solution for this problem. I really would like to start using KMS as our mailserver solution but can?t get this iCal/Addressbook issue resolved.

Is there any log file on KMS that I could look into to see if the server even recieves calls for iCal?

- Janne


Sure. There is a debug log in KMS which would help us. Just enable HTTP server and WebDAV debug logging (right click in the debug log).


Actually now I found from Security log:
[01/Nov/2006 10:01:30] HTTP request from MY_IP_NUMBER (GET /) redirected to HTTPS because of security policy.
[01/Nov/2006 11:08:09] HTTP request from MY_IP_NUMBER (GET /ical) redirected to HTTPS because of security policy.

Should I change the security policy to some non-secure option or so?


I?ll answer to myself. I got the iCal working by changing the security policys in "advanced options".

But I still can?t find any contacts with addressbook. I dont?t get any errors in administration console either. I have tried to add contacts to public and private folders etc.
  •  
ybekkering

Messages: 20
Karma: 0
Send a private message to this user
You don't see any contacts in Address Book, but you have to type a search-string in the search-box (for example: be -> it should display all names containing "be")

In Addressbook, Preferences just fill in the DNS-name of your KMS (for example www.example.nl)
Leave the port at 389 (or if you changed it in adminconsole you have to use that port)
Select subhierarchie (substructure ?)
and fill in your username/password and select simple authentication.

That should work.......
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
You can also use iSync synchronization in Apple Address Book if you're running Mac OS X Tiger. All your contact will be synchronized between AddressBook and KMS.
For details see: http://www.kerio.com/manual/macsup/en/ch04s02.html
  •  
cuie

Messages: 15
Karma: 0
Send a private message to this user
ybekkering wrote on Wed, 01 November 2006 15:39

You don't see any contacts in Address Book, but you have to type a search-string in the search-box (for example: be -> it should display all names containing "be")

In Addressbook, Preferences just fill in the DNS-name of your KMS (for example www.example.nl)
Leave the port at 389 (or if you changed it in adminconsole you have to use that port)
Select subhierarchie (substructure ?)
and fill in your username/password and select simple authentication.

That should work.......


This helped, thanks!:)
Previous Topic: Cannot paste *.cfg from old machine to new machine
Next Topic: KOC Locking up with Outlook 2003
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 12:54:47 CET 2017

Total time taken to generate the page: 0.00526 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.